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OVERVIEW _____________________________________________
Welcome to the Shure P4800 System Processor software guide. This document will help you understand how
the P4800 functions as you learn to use the software interface. The hardware stands alone as both a front-end
and back-end system processor that can be externally controlled by a simple end-user interface. The software
is the tool that configures the device's internal signal routing and audio processing. It is designed for small and
medium sized sound systems that need the power and flexibility that a digital signal processor can provide, but
also require a unit that's easy for the installer to configure and simple for the end user to work with.

Document Structure
The P4800 software interface is so intuitive and user friendly that you may be tempted to skip reading this
document and immediately begin programming the unit. Before you do, however, you should at least skim this
overview, then thoroughly read the Start-Up Guide on page 12. Any questions you have about the software will
be answered in the following sections of the document.
§

Overview ................................... Introduces the main features of the System Processor, and
discusses the operating modes of the interface and the main window.

§

Start-Up Guide.......................... Covers the basic steps you need to follow with the
software to set up the System Processor for an installation.

§

Creating a Configuration......... Covers the elements of a System Processor signal flow
configuration, such as the gain structure of the device, routing signal from inputs to outputs,
adding processors to the signal path, and working with them in the main window.

§

Saving a Configuration............ Explains how to save a configuration to the computer, store
it as a preset in the P4800, and backup the contents of the device to computer.

§

Processor Features ................. Covers the features that are common among many of the
signal processor modules, such as fader controls, taking snapshots of parameter settings, and
saving and recalling settings to and from the computer.

§

Fixed Processors ..................... Explains the features of the input and output gain
processors and the Matrix Mixer.

§

Modular Processors ................ Explains the features specific to each of the modular
signal processors.

§

Control Pins.............................. Describes the internal architecture of the System
Processor's external device control feature and explains how to configure the P4800's
control pins with the software once the external hardware has been connected.

§

Security ..................................... Covers the security features of the System Processor
that restrict user access to device settings.

System Processor Features
The P4800 is a 4-input, 8-output digital audio processor with a software interface that completely replaces front
panel controls. It provides 24-bit conversion, 48khz sampling and a minimum dynamic range of 100dB.
SoundPlex digital signal processing ensures high performance and system stability. The device stores from 16
up to 128 user-defined presets, depending on the complexity of the configurations.

Drag and Drop Software Interface
The computer interface to the System Processor mimics the functional block diagrams used in sound
system design. This makes the software incredibly easy to learn, because the interface seems
immediately familiar to sound professionals. System configurations can be built and edited entirely by
clicking, dragging, and dropping with the mouse. The digital signal processing is highly configurable,
with modular signal processors that can be arranged in any user-defined order.
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Modular Signal Processors
Each signal processing module is encapsulated in a graphic block that you can manipulate with the
mouse. You can access the processor settings by double-clicking on the block to open its parameter
window. Settings can be saved and recalled from the computer, and copied between similar modules.
Processor settings can also be synchronized via the link feature. The P4800 includes the following
selection of signal processor modules.

§

Shure's Powerful Digital Feedback Reducer

§ Gate/Expander
§ Mono and Stereo Compressor/Limiter with SoftKnee Option

§

Automatic Gain Control and Leveler

§

Combining and Non-Combining 10 and 30-Band
Graphic Equalizers

§ Ducker

§

3 to 10-Band Parametric Equalizers with Cut
and Shelf Filters

§ Peak Stop Limiter

§

2 to 5 Way Crossovers and Splitter

External Device Control
After it is installed and programmed with the software interface, the System Processor can be controlled
with a simple hardware interface, as well as with a computer or MIDI device. The control pins on the rear
panel can be connected to external hardware, so that the P4800 will respond to contact closures,
potentiometers, and wall-plate switches. The output pins can be configured to indicate preset and mute
status to LED's, control relays, or other equipment.

Security
The security feature gives the installer peace of mind that the device cannot be tampered with after it is
installed. User access can be completely restricted so that the user cannot change any settings, or even
switch presets. They will only be able to view the settings of the current preset from the software interface.
End-user control can also be customized to allow access to certain settings, and not to others.

P4800 Software Minimum Requirements
The P4800 Software Version 4 requires a PC with the following specifications to function properly:
§ 20 MB available hard disk space
§ CD-ROM drive
§ VGA monitor with 640 x 480/256 color, or higher resolution
§ Mouse or other pointing device
Processor speed and memory requirements vary, depending on the version of Windows and number
of background applications you are running. Operating the P4800 software simultaneously with
programs such as SIA-Smaart or Gold Line TEF™ requires a faster processor and more RAM. The
following table lists the minimum requirements for running the P4800 software with no other
applications in the background, including virus protection, firewall, instant messaging, or email.
Windows Version

Processor Speed

RAM

95, 95B, and 98

Pentium 166 MHz

32 MB

98, Second Edition

Pentium 166 MHz

48 MB

NT

Pentium 233 MHz

64 MB

ME

Pentium 300 MHz

64 MB

2000 Professional

Pentium 300 MHz

96 MB

XP Professional, Home

Pentium 300 MHz

128 MB
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Interface Modes
The Interface features two primary modes of operation: Design Mode and Live Mode. This provides you with the
option of creating configurations for the System Processor regardless of whether or not the computer is connected to
the device. There are certain functions that are specific to each mode, which are explained throughout the manual.

Design Mode
When you launch the application, you always begin in Design Mode. This is the mode you use to
create presets that are later stored in the System Processor. In this mode, it is not necessary for the
computer to be connected to the device. You can save the signal flow configurations you create to
scene files on the computer, which may later be recalled and sent to the device through the RS-232
connection. This provides you with the capability to design presets in a location other than where the
equipment is installed. Scene files are analogous to presets in every aspect, except that they are
stored on the computer rather than in the device.

Live Mode
This mode allows you to make real-time adjustments to hardware presets while the computer is
connected to the System Processor. This provides you with the means to instantly hear changes to
signal processing as you alter settings, so you can easily refine your presets on site. Everything you do
in Live Mode is written directly to the current live preset.

Preview Mode
When working in Live Mode with a device that contains multiple presets, you may recall them
individually for real-time modification. When you select a preset to load into the signal flow diagram,
the window enters preview mode to give you the opportunity to verify your selection before you
designate it as the next live preset. The interface returns to Live Mode when you load the preset, or
cancel the operation.
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Main Window
This window, shown below in figure 1, is your primary workspace in the software interface. You can size it
proportionally larger, or maximize it to take up your entire screen. Closing this window exits the application.

Figure 1 − Main Window

1.

Title Bar
The information on the title bar of this window changes depending upon the operating mode. In
Design Mode the title bar reads, “P4800: Offline,” and indicates the default security level. In Live
Mode, it displays information specific to the unit to which you are connected, as illustrated below in
figure 2.

Figure 2 − Title Bar in Live Mode

The device ID number is specified by setting the DIP switches on the back of the device; and both
the device name and security level are specified from the [Device] menu when you are in Live Mode.

2. Main Menu
Some menu options are mode-specific, and are grayed out depending on which mode you are
currently working in. Contextual menus are also available by clicking the right mouse button when
your cursor is positioned in the signal flow diagram (number eleven below).
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3. Control Bar
This section of the window changes in appearance and function depending upon the operating
mode. When you are in Live Mode the control bar emulates the LED meters on the front panel of
the hardware, as pictured below in figure 3.

Figure 3 − Control Bar in Live Mode

The meters can be toggled on and off by clicking on them with the left mouse button, or by
selecting [View > Enable I/O Meters] from the main menu.

Figure 4 − Control Bar in Preview Mode

In preview mode, as pictured above in figure 4, the control bar provides you with the choice of loading
the preset you have selected, or canceling the operation and returning to the previous live preset.

4. Live Mode Switch
Click this button to switch to Live Mode, which enables you to preview and edit any preset currently
stored in the hardware. Your computer must be connected to the P4800 to enter this mode.

5. Design Mode Switch
Click this button to switch to Design Mode. The preset you were working with in Live Mode
remains loaded in the signal flow diagram, which allows you to use the current preset as a basic
template, creating multiple presets by repeatedly storing it to the device.

6. Information Box
This displays details about the preset or scene file that is currently loaded on the screen, including
name, date last saved, and description. In Live Mode, a pull-down menu appears in the name
field, which lists all presets stored in the device (see Figure 3. – Control Bar in Live Mode).

7. Store Preset
This button is available only in Design Mode. Click to store the current signal flow diagram settings
as a hardware preset in the System Processor.

8. Recall Preset
This button is available only in Design Mode. Click to load a preset from the System Processor
into the signal flow diagram.

9. Save As
Click this button to save the current signal flow configuration and settings to a scene file.

10. Open
This button is available only in Design Mode. Click to load the contents of a scene file into the signal
flow diagram.
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11. Signal Flow Diagram
The signal flow diagram depicts how audio signals pass through the various processors in the
hardware. It shows audio signal flow as moving from left to right along the input and output
channel strips. Each channel strip contains fixed components for adjusting gain and mixing
channels. They also contain a series of empty slots for adding different types of processing.

12. Input Channel Strip
The input channel strips correspond to the four input channels of the System Processor. Each strip
accommodates up to five different signal processors.

13. Input Channel Label
This displays the channel label that you specify in the Input Gain window.

14. Input Gain
This is the initial stage of the System Processor’s gain structure. Double-clicking this block opens
the Input Gain window, which provides you with –10dBV/+4dBu scaling options, channel mute,
polarity control, and a +/–30dB fader for each input channel. This is also where you name your
input channels.

15. Mode Indicator
This displays the current mode of the signal flow diagram, as illustrated below.
Design Mode

Live Mode

Preview Mode

16. Input Selector
Click on these numbered input selectors at the mix point of each output strip to connect
automatically with the corresponding input channel mix point.

17. Matrix Mixer
This is the intermediate stage of the System Processor’s gain structure. Double-clicking this block
opens the Matrix Mixer window, where you can route signal from any input channel strip to any output
channel strip, and adjust relative levels with fader controls. This window has a separate tab for each
output channel strip that displays gain, polarity, and mute controls for every input channel connected to
its mix point.

18. Channel Numbers
These numbers correspond to each of the four input and eight output channels of the P4800.

19. Mix Points
Click on these points to route signal between input strips and output strips. Lines appear between
points that are connected, depicting the signal flow. Each input strip may be connected to any or
all output strips.

20. Processor Slots
These slots serve as containers for processor modules. They can be populated either by using the
drag and drop method from the Processor Toolbox, the [Add Processor] option on the main menu,
or the contextual menu available with a click of the right mouse button.
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21. Output Gain
Double-clicking this block opens the Output Gain window, which provides you with -10dBV/+4dBu
scaling options, channel mute, polarity control, a –20dB pad, and a +/-30dB fader for each output
channel. This is the final stage of the System Processor’s gain structure. This is also where you can
designate a custom name for your output channel that pertains to your particular setup.

22. Output Channel Label
This displays the channel label designated in the Output Gain window.

23. Output Strip
The output channel strips correspond to the eight output channels of the System Processor. Each
strip accommodates up to six different signal processors.

24. Mute All Inputs
Click this control to automatically mute all input channels.

25. Mute All Outputs
Click this control to automatically mute all output channels.

26. DSP Usage Meter
This indicates the percentage of the P4800's digital signal processing resources that is taken up
by the current configuration of processor blocks that you have placed in the signal flow diagram.
The meter displays a green bar that expands as usage increases.

27. Delay Memory Meter
This indicates the percentage of delay memory that is taken up by the delay processors you have
placed in the signal flow diagram. The meter displays a blue bar that expands as usage increases.

The Processor Toolbox
The Processor Toolbox appears next to the main window when you launch the application, as shown in figure 5.
This window displays the library of processor modules that you can drag and drop onto empty slots in the signal
flow diagram. It can be resized vertically by dragging the top or bottom edge up or down. A scroll bar appears on
the right-hand side so you can access every processor block, regardless of the height of the window.

Showing and Hiding
The Processor Toolbox window appears in front of the main window. You can close
it by clicking on the [X] in the right-hand corner of the title bar, or by going to the
main menu and selecting [View > Show Processor
Toolbox]. To re-open the Processor Toolbox window,
Drop Down Button
select [View > Show Processor Toolbox] again. A check
mark appears next to the menu option when the Processor
Toolbox window is open.

>

Drop-Down Buttons

Processor Blocks

>

A drop-down button appears over each processor category in the Processor Toolbox.
Click on a drop-down button to show or hide all processor blocks within that
category.

Processor Blocks
Processor blocks are the graphical representation of processor modules.
Figure 5 − Processor Toolbox
After you place them on the signal flow diagram, you can access settings
by double-clicking on each block to open its parameter window. The percentage of digital signal processing
resources that each processor module uses is displayed to the right of each block in the processor toolbox.
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START-UP GUIDE ________________________________________
The start-up guide covers the basic steps required for complete set up of the System Processor. Before
attempting to follow these instructions, you should familiarize yourself with the Overview section, which
introduces some basic features of the software interface.
You can perform many of these steps without actually being connected to the device, by saving your configurations
to the computer and transferring them to the hardware at a later time. In order to acquaint you fully with the features
of the System Processor, these instructions are written presuming the following conditions:

§
§
§

You are working while connected to the device.
The installation includes external device control.
Device security is required.

You may find steps in the instructions that do not apply to your immediate installation. However, we suggest
that you follow along through the entire Start-Up Guide, in order to acquaint yourself with the recommended
workflow of setting up the device, for future reference.

Install Software
If you have not already installed the software, follow these instructions to install the application
from the CD-ROM.
1.

To install the software from the CD-ROM:
Insert the CD into the CD-ROM drive of your computer.

2.

The installation program will start automatically. Follow the on-screen instructions.

3.

4.
5.

If installation does not begin automatically:
Click on the [Start] button on the Windows Taskbar and select [Run…]
from the pop-up menu
Type "D:\setup" (where "D" is your CD-ROM drive).The installation program will start
automatically. Follow the on-screen instructions.
Click [OK] and follow the instructions of the installation program.

If you have downloaded a copy of the software, locate the ".exe" file in the Windows Explorer
and open it. Follow the instructions of the installation program.

Establish Communication
This is the procedure to use when you initially connect the computer to the device. It is your first
opportunity to verify that your computer and the P4800 are communicating properly. For more
information on connecting your computer to the device and setting the device ID, see the Computer
Connections section of the Hardware Installation Guide.

1. Connect the computer to the System Processor
Connect your computer's COM port to the RS-232 serial port on the front or rear panel of the P4800.

2. Launch the software application
3. Select the COM Port
a)

Select [Devices>Select COM Port] from the main menu

b)

The Select COM Port dialog opens, as pictured in figure 6
on the right.

c)

Choose the COM port that the RS-232 cable is connected
to and click [OK].
Figure 6 − Select COM Port Dialog
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4. Go Live with the System Processor
a)

Click the [Live Mode] button on the control bar of the main
window.

b)

The Select Devices dialog opens, listing all available devices, as
pictured in figure 7 on the right. The ID number indicated on the
left side of the list is set with DIP switches on the back of the
device.

c)

Select the System Processor unit you will be working with and
click [Connect].

d)

The software interface enters Live Mode, indicated by the blue
color of the signal flow diagram and the signal meters displayed
on the control bar.

Figure 7 − Select Devices Dialog

5. Name the Device
a)

Select [Devices>Name Device] from the main menu.

b)

The Name Devices dialog appears, as pictured in figure 8
on the right.

c)

Enter a device name, up to fifteen characters long and
click [Name].

d)

The device name appears on the title bar of the main
window when you are in Live Mode, and is listed in the
[Devices] menu.

Figure 8 − Name Device Dialog

Configure External Control
If there are external devices connected to the control pins, you need to configure the device to
recognize the external controllers. This configuration is stored at the device level and should be
established before you create any presets. If you are not connected to the device, you can create a
configuration and save it on the computer to be later transferred to the P4800 through the RS-232
connection. Refer to the Control Pins section on page 76 for complete instructions.

1. Enter Design Mode
You must be in Design Mode to configure external control. If you are in Live Mode, click the [Design
Mode] button on the control bar of the main window.

2. Configure Control Pins
Select [Devices>Control Pin Configuration] from the main menu, which opens the Control Pins window.
Start by selecting how many presets you will be switching between, and the type of encoding the device
will use for the preset numbers, then specify the other control connections.

3. Save the Configuration to the Device or to PC
Select the [Configuration>Store to Device] or [Configuration>Save to PC] menu option.

Note:

If you need to switch presets from the computer after you have configured the
control input connections, you must disable the connections in the Control Pins
window before proceeding further.
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Create a Signal Flow Template
This can be done in either Live Mode or Design Mode. When you are storing multiple presets in the System
Processor, you will save considerable time by creating a signal flow template that contains the attributes
that will be common among them. This template can then be recalled from the device or opened from a
scene file on PC, revised as necessary, then stored in the device each time as a new preset.

1. Name Input and Output Channels
Double-click on the input and output gain blocks to open the processor parameter windows, and edit the
channel labels that appear underneath the gain controls. For more information, refer to the Labeling
Inputs and Outputs section on page 17.

2. Populate the Signal Flow Diagram
Drag and drop signal processor blocks from the Processor Toolbox onto the signal flow diagram. If you
are using crossovers, they should be the first type of processor that you place in the configuration,
followed by limiters, in order to prevent loudspeaker damage. For more information, refer to the Adding
Processors section on page 20.

3. Create Link Groups
CTRL+Click to select multiple processors of the same type that you would like to control as a group, for
stereo pairs, loudspeaker clusters, zones, etc. You can also link gain blocks in order to control overall
system level. For more information, refer to the Linking section on page 25.

4. Trim Output Levels
Double-click on the output gain blocks to open the Output Gain window. Reduce the output gain of each
channel by –30dB to prevent loud signal from passing through the system. If output channels are linked,
you need to adjust only one fader to change all linked channels to the same level.

5. Route Signal from Inputs to Outputs
Click and drag from input strip connection points to output strip connection points to route the signal through
the Matrix Mixer. For more information, refer to the Signal Routing section on page 18.

6. Adjust Processor Settings
Double-click on each processor block to open its parameter window. If you are working off-line in
Design Mode, you can set preliminary levels and tweak them later when you are connected to the
device. For more information on working with processors, refer to the Processor Features section on
page 31, as well as the reference section for each processor.

7. Map Processors to Control Connections
Each preset must contain a map to the control pin connections for the hardware to recognize the
external devices when the preset is active. Open the Control Pin window and select the checkboxes
next to the input and output channels that each control connection will address. For more information,
refer to the Control Pins section on page 76.

8. Lock Processors for Read-Only Access
This step is applicable only when you are customizing security for the end user. This type of security is
stored with each processor, at the preset level. Select the processors that the user should not be able to
modify, and select [Security>Level 2>Lock Selected] from the main menu. For a complete explanation
and further instructions, refer to the Individual Processor Security section on page 87.
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9. Name the Preset
Click once with the left mouse button anywhere in the
information box in the center of the control bar to open the
Preset Information dialog, as pictured on the right in figure
9. Enter a name for the preset, up to 15 characters long,
and a description, then click [OK]. For more information,
refer to the Naming a Preset or Scene File section on
page 19.
Figure 9 − Preset Information Dialog

10. Store the Finished Preset in the Device
If you are working in Live Mode, the preset is already stored in the device. If you are working in
Design Mode, click the [Store Preset] button on the control bar of the main window. For more
information, refer to the Preset Management section on page 28. To duplicate this preset you need to
be in Design Mode. Simply continue to click the [Store Preset] button, creating duplicates until you have
stored as many presets in the device as you require.

11. Enable External Control
Once you are finished creating and editing presets, if you previously disabled control connections
in order to control the System Processor via the computer, open the Control Pins window and reenable them.

Establish Security
This is the final step in setting up the device. Before continuing, you should thoroughly read the
Security section on page 85. These instructions are intended only as an overview of the process.

1. Go Live with the System Processor.
You must be in Live Mode to set device security. If you are in Design Mode, click the [Live Mode] button
on the control bar of the main window.

2. Set a Password
Select [Security>Set Password] from the main menu, which opens the Create Password dialog. Type in
a password, press TAB, and then type it again to confirm. Click [OK].

3. Set the User Access Level
Select [Security>Set Level] from the main menu, which opens the Set Security dialog. Select the
appropriate user access level. Click [OK].
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CREATING A CONFIGURATION ____________________________
A configuration is a unique combination of signal routing connections, the selection and placement of modular
processors, and processor settings. You create the configuration in the signal flow diagram of the main window,
and save it either as a preset in the device, a scene file on the computer, or both. The System Processor
initially is loaded simply with a blank preset, meaning there are no signal routing connections in the device, and
no signal processing taking place.

Signal Flow Configuration
In order to pass audio through the device, you must route signal from the inputs to the outputs by connecting
mix points. This section explains the basics of signal flow design in the System Processor user interface.

Gain Structure
The System Processor provides gain control at three stages of the signal flow: input gain, matrix mixer,
and output gain. It is essential to obtain an understanding of this gain structure before passing audio
through the unit, in order to avoid damaging equipment that is in line after the System Processor with
excessive gain levels. The following illustration provides an overview of the P4800 gain structure.

Adjusts signal gain after it
is digitally converted and
before it's processed on
the input channel strip.

Routes the signal from input
to output, and adjusts signal
gain before output channel
processing.

Final gain adjustment of
processed digital signal
before analog conversion
at device output.

Figure 10 − P4800 Gain Structure

Input Gain
Double-clicking on any input gain block will open the Input Gain processor window, which displays
controls for all four channels. It acts as a pre-processing trim; providing scaling, gain and polarity control
for each channel, and allows you to designate custom names for your input channel strips.

Note:

Signal levels exceeding the input threshold of the System Processor must be
adjusted externally to prevent clipping at the A/D converters.

This is a signal’s point of entry to the signal flow diagram. After the input gain processor, the signal
passes sequentially through the processor slots on its input channel strip. At the end of the channel
strip, the signal arrives at a mix point, where it can be routed to any or all outputs via the matrix mixer.
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Matrix Mixer
Once a signal has been routed to the mix point of an output channel strip, it enters the matrix mixer
stage of the gain structure. Double-click on any mix block to open the Matrix Mixer processor window,
which displays a pane for each output channel strip. When crossovers are placed over multiple output
channels, the mixer panes for those channels will combine to reflect that configuration. Use this
window to adjust the polarity and relative levels of all inputs routed to the selected output channel.
After the matrix mixer, the signal passes sequentially through the processor slots on the designated
output strip. At the end of the channel strip, the signal arrives at the output gain block.

Output Gain
This is the final stage of gain control in the System Processor. Double-click on any output gain block to
open the Output Gain processor window. It acts as a post-processing trim; providing scaling, gain,
polarity control, and an optional 20dB pad for each channel. This window also allows you to designate
custom names for your output channel strips. After the output gain processor, the signal passes through
the D/A converter, to the audio output.

Muting Channels
There are several ways to mute the input and output channels of the System Processor. Muted
channels are flagged in the signal flow diagram, as illustrated in the following table.
Gain Block

Inputs 3 & 4
to Matrix Mixer

Output from
Matrix Mixer

Crossover Output
Channels

Muting All Inputs or Outputs
§
§
§

Click either the Mute All Inputs or Mute All Outputs control located at the bottom of the
main window.
Select either the [Processor>Mute All Inputs] or the [Processor>Mute All Outputs]
menu option.
Power off the device to automatically mute all outputs.

Muting Individual Channels
1.
2.
3.

Open the Input Gain, Matrix Mixer, or Output Gain window by double-clicking the appropriate gain
or mix block.
Click the mute button for the appropriate channel.
The block will be flagged with a red "M" to indicate that it is muted.

Labeling Inputs and Outputs
Inputs and outputs are untitled when you create a new scene file, but they are easily changed using the
Input Gain and/or Output Gain windows. Channel labels are saved along with the preset or scene file, so
you can customize label inputs and outputs for every system configuration.
1.
2.
3.
4.
5.

To change a channel label:
Double-click on the channel’s gain block.
In the processor window, locate the channel’s label box.
Click and drag over the text to highlight it.
Type in a new label of no more than fifteen characters.
Apply the changes by clicking on another control or closing the window.
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Signal Routing
The System Processor allows you to route signal from each of the four inputs to any or all of the eight
outputs. In order for signal to pass from the input channel strips to the output channel strips, it must be
routed through the Matrix Mixer. You can connect inputs to outputs using any of the methods
described below.

Making Connections in the Signal Flow Diagram
For simple system configurations, the easiest way to connect inputs to outputs is to use the mouse in
the signal flow diagram.

Click on Mix Points
1.
2.
3.

Click on an input mix point.
The cursor will change to indicate it’s waiting for you to designate an output connection.
Click on an output mix point.

Tip!

You can use the ESC key to cancel a connection if you change your mind after
you have clicked on an input mix point, before you click on an output mix point.

Click and Drag between Mix Points
1.
2.
3.

Click and drag from an input mix point to an output mix point.
A connection line will appear along the signal path.
It turns green when the connection is valid.
Release the mouse button to make the connection.

Click on Input Selectors
1.
2.

Click on an output channel’s numbered input selector for the corresponding input channel.
A connection line will appear in the signal flow diagram between the mix points, and the numbered
input selector will be highlighted.

Making Connections in the Matrix Mixer Window
For more complex configurations with many crossing connection lines, the Matrix Mixer window can
provide an easier method of connecting inputs to outputs.
1. Double-click on the mix block for the output you wish to connect.
2. In the left side of the Matrix Mixer window, click the input button for each input
channel connection.
3. A connection line will appear in the signal flow diagram between the mix points, and the numbered
input selector will be highlighted for each active connection.

Deleting Connections
§
§
§
§

Click on a connection line and press the DELETE key.
Click on the input selector corresponding to the connection.
This toggles the connection off.
Click on a connection line and use the right-click contextual menu.
Select multiple connections by holding down the CTRL key while clicking.
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Naming a Preset or Scene File
Since you can store up to 128 different presets in the System Processor, it can be helpful to
differentiate them with a name and a brief description. The information box in the center of the control
bar of the main window displays these details, as pictured below in figure 11.

Figure 11 − Information Box

The name you enter here becomes both the name of the preset when you store the configuration to
the device, and the name of the scene file when you save it to PC. The description will also be
displayed in all the dialog boxes that list presets or scene files. You can revise these details at any
time in either Live Mode or Design Mode.

1.
2.
3.
4.
5.

To name a preset or scene file:
Click once with the left mouse button anywhere in the
Information Box.
The Information dialog opens.
Enter a name with a maximum of 15 characters and a
description with a maximum of 80 characters.
Click [OK].
The Information Box updates to reflect your changes.

Figure 12 − Scene Information Dialog

Processor Configuration
There are two levels of working with processors: at the configuration level in the signal flow diagram, and within
each processor’s individual parameter window, which is accessed by double-clicking on the processor block.
This section covers working with processors in the signal flow diagram, and explains the differences between
the two main categories of processors.

Processor Types
You will be working with two main types of processors in the signal flow diagram: fixed and modular. The
primary distinction between them is that fixed processors are part of the gain structure of the P4800, and
are therefore part of every signal flow configuration. Modular processors are the processor blocks that you
select and position any way you'd like to suit your particular system requirements.

Fixed Processors
The gain and mix blocks are called fixed processors because their locations on the channel strips are
permanent. They cannot be deleted, moved, copied, or pasted. However they can be linked, and their
settings can be saved and recalled.

Modular Processors
The modular processor blocks are called modular because they can be placed on any empty slot
(excepting crossovers, splitters, and the ducker), and freely moved, copied, pasted and deleted. Each
processor block on the signal flow diagram functions independently. When you open the parameter
window of a modular processor, you are changing settings for that block only, except under the
following conditions.
§ It is half of a stereo pair.
§ It is assigned it to a link group.
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Adding Processors
Each channel strip has a row of empty slots that can contain any of the modular processor blocks.
Except for crossovers and splitters, there are no restrictions on where processors can be placed on the
signal flow diagram, or how many times you can use a given processor on the same channel strip.
Empty slots between processors do not affect the signal flow, so blocks do not have to be adjacent on
the channel strips.
When processor blocks are first added to the signal flow diagram, they contain factory default settings.
You can individually change each processor’s settings by opening its parameter window. The blocks
will retain their settings even when copied or moved to a different slot.

Populating Empty Slots
Processor blocks can be added to the signal flow diagram either by using the Processor Toolbox, or by
menu command. Each method is described below.

With the Processor Toolbox
You can use the mouse to grab a processor block from the Processor Toolbox. The mouse cursor will
change to alert you that your next mouse action will place the block in the signal flow diagram. The
cursor’s appearance depends on its location, as illustrated in the following table.
Location where processor
can be placed
Inappropriate location for
that processor.
To add a processor block from the Processor Toolbox:
§ Click and hold the left mouse button to drag a processor block from the Processor
Toolbox to the signal flow diagram. Release the mouse button to place the block at the
current cursor location.
- OR -

§

Click once on a processor block in the Processor Toolbox, then click again on the
appropriate empty slot in the signal flow diagram.

Tip!

If you change your mind after you have clicked on a processor block in the
Processor Toolbox window, you can use the ESC key to cancel this operation
before you place the processor in the signal flow diagram.

With a Menu Command
You can add processors to the signal flow diagram without opening the Processor Toolbox, by using
either the main menu or the right-click contextual menu, as described below.
To add a processor block using the menu:
1. Click to select an empty slot.
2. Use the right-click contextual menu to select a processor.
- OR 3.

Use the [Processor>Add] option on the main menu bar.

Another advantage to using a menu command to place your processor blocks is that you can place the
same type of processor in multiple slots with a single menu command.
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To add multiple processor blocks:
1. CTRL+Click to select multiple empty slots.
2. Use the right-click contextual menu to place the same type of processor in every
selected slot.
- OR 3.

Use the [Processor>Add] option on the main menu bar.

Stereo Processors
Stereo processors are placed in the signal flow diagram in much the same way as the other modular
processor blocks. However, each of the stereo channels appears as a separate block. Double-clicking
on either block will open the parameter window for both channels.
Each of the following dynamic processors will operate as a stereo pair:

§
§
§
§

Block Name

Description

ST COMP
SFT ST COMP
ST LIM
SFT ST LIM

Stereo Compressor
Stereo Compressor − Soft Knee Option
Stereo Limiter
Stereo Limiter − Soft Knee Option

To add a stereo processor block from the Processor Toolbox:
1.

Click on a processor block

When you select a stereo processor from the Processor Toolbox, the cursor will appear somewhat
differently than it does for other processors, as pictured in the following table.
Location where the first channel of
the stereo processor can be placed.
Location where the second channel of
the stereo processor can be placed.
2. Add the first channel of the stereo pair.
§ Click and hold the left mouse button to drag a processor block from the Processor
Toolbox to the signal flow diagram. Release the mouse button to place the first processor
channel at the current cursor location.
- OR § Click once on a processor block in the Processor Toolbox, then click again on the
appropriate empty slot in the signal flow diagram.
3.

§

The cursor changes to indicate you must place the second channel of the processor.
Click on the appropriate slot to add the second stereo channel.

To add a stereo processor using the menu:
1. CTRL+Click to select empty slots on two different channels.
2. Use the right-click contextual menu to place both channels of the stereo pair.
- OR 3. Use the [Processor>Add] option on the main menu bar.
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Crossovers and Splitters
Since they are output processors, crossovers can only be placed on output channel strips. They can be
added to output strips like any other processor block, but you must take into account the following:
§ A crossover extends downward to span the specified number of outputs, so you must
select a channel strip that has enough outputs below it.
§ A crossover block can only span consecutive outputs.
§ Crossovers cannot overlap on any output strips.
§ Mix points will disappear from all outputs spanned by the crossover, except the top
channel strip.
§ Processor slots to the left of the crossover will disappear from outputs below the top strip.
§ Splitters possess the same signal flow ramifications and restrictions as crossovers.
If your configuration calls for crossovers, they should be added to the signal flow diagram before you
connect mix points or add other processors to the output channel strips.

Ducker
The ducker should be placed only on the input channel strip that carries the paging signal. The system
will not allow you to place a ducker on an output strip.

Replacing Processors
Only one processor block at a time can occupy a given slot. To replace an existing processor with another,
first delete it from the slot then add the new processor using any of the methods described above.

Managing DSP Resources
Although the P4800 has sufficient processing power for many applications, it is possible to populate
the signal flow diagram with more processor blocks than the device's DSP (digital signal processing)
resources can handle. This section explains in general terms how the System Processor manages the
signal processing requirements of a configuration, and gives you some hints on how to get the most
out of the DSP resources.

Resource Allocation
By placing a processor block on a channel strip, you are allocating the DSP resources necessary for it to
run at its maximum capacity. This is why so many varieties of the same type of processor blocks are
provided; so that you can select only the amount of processing you actually need for a given module. When
you are designing a simple configuration, it is not critical to pay attention to how much DSP is being utilized.
However, the more complicated the configuration, the more important it is to select processor blocks that
use the minimal processing resources necessary to get the job done.
For example: when you place a ten-band parametric EQ on a channel strip, you will instantly allocate
the processing power required by all ten filters, even if you are only using four of them. The PEQ5
would be the best choice, in this instance.

Delay Memory
The System Processor has a memory buffer that will hold up to 20 seconds of delay time, which you
can divide among any combination of delay processors. Like DSP resources, delay memory is
allocated to each processor block according to the maximum delay time indicated in the block name.
For example, if you need 45 ms of delay, don’t use the 2-second delay when the 150ms delay will
do just as well. Even though both processors may be set to the same values, the DLY 2s block still
occupies a full two seconds of delay memory.

Note:

Do not confuse delay memory with DSP resources. Each delay utilizes the same
amount of DSP, regardless of its maximum delay time.
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DSP Usage Meters
These meters, located at the bottom of the main window, indicate the amount of DSP resources and
delay memory utilized by the current configuration. Knowing the amount of DSP resources and delay
memory you have left enables you to manage your processor choices efficiently. When you add or
remove a processor block from the signal flow diagram the DSP meter instantly compiles the results,
and indicates the system resources that are being utilized by the current processor configuration.

Note:

The DSP usage meter indicates the percentage of total resources the preset is
occupying, not than the amount of resources the processors consume individually.

Because the P4800 performs DSP with multiple processor chips, the DSP meter may not accurately
represent the amount of available resources. If the meter indicates 20% is available, but you can't add a
processor, it may be because the available resources are divided between the processor chips, rather than
being available in one place. Refer to the DSP Optimization Hints paragraph below for some solutions.

Note:

P4800 units with a serial number starting with the letter N or higher will allow you
to story any scene that you can create in Design Mode. For older units (indicated
by a serial number starting with L or M) scenes that use less than 87%, as
indicated by the DSP meter should be usable. However, because resources are
allocated across multiple processor chips, the meter may not precisely represent
available DSP capacity. It is possible than an older unit may not be able to use a
scene even if the DSP meter reads less than 87%. This may happen if your
scene uses multiple DFR5, DFR10, and/or GEQ30 blocks. To ensure that a
scene will be usable on a P4800 with a serial number starting with L or M, you
should connect to the unit and go to Live Mode. In Live Mode, the DSP meter
and processor usage percentages listed in the Processor Toolbox will be scaled
to accurately reflect the capacity of the unit.

DSP Optimization Hints
If the message box shown in figure 13 appears when you
attempt to add a processor, optimize your configuration to free
up DSP resources, then add the processor. The following hints
will help you optimize DSP resources.

§

Move processor blocks from one side of the matrix mixer
to the other, beginning with the ones that consume the
highest percentage of DSP resources (see Appendix B:
DSP Usage Per Processor on page 102 for details on
processor DSP usage).
Example: move a DFR10 from the output side of the
signal flow diagram to the input side, or vise versa.

§

Figure 13 − DSP Resources Message

Consolidate multiple EQs on the same signal path into a single module, if possible.
Example: two PEQ3s consume more DSP than a PEQ7. Note that all PEQ's are available
with cut and shelf filters in order to conserve DSP. The only feature specific to the
CUT/SHELF module is the 24dB/oct slope. If you don't require this feature, it is not
necessary to include cut and shelf filters in a separate module on the same signal path.

§

Consolidate multiple delays on the same signal path into a single module, if possible.
Using two DLY5ms blocks to achieve 7 ms of delay uses twice as much DSP than a
single DLY150ms block, even though it conserves Delay memory.
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§

Add processors to the input side of the matrix mixer, instead of the output side, if possible.

§

Remove processors from any unused channels.

§

Use splitters to consolidate identical signal processing on multiple output channels.

§

Use a PEQ10 instead of a GEQ30. In most cases, you will not use all thirty filters on the
GEQ30, and the PEQ10 uses less than half as much DSP.

§

Replace DFRs with parametric EQs after you are finished ringing out the system.
For example: in a configuration where multiple DFRs are needed on multiple inputs for better
gain before feedback performance, you could initially use a DFR on each input for ringing out
the system. After the filters are deployed, copy the DFR filters and paste them in a PEQ, then
delete the DFR. You can repeat this for each input and finally leave only one DFR in the most
offending loudspeaker output for later automatic feedback detection.

Note:

After you have optimized your configuration, the DSP meter may not reflect a
change, because the total percent available is actually the same. The resources
have just been re-allocated so that you can utilize them more fully.

Copy and Paste
The traditional copy, cut and paste commands function only on the modular processor blocks. This is a
convenient way to duplicate processor blocks along with their settings across multiple channels.
1.
2.

3.
4.

To copy and paste a processor block:
Select a processor block with a single left mouse click.
Select the copy command using one of the following methods.
§ Use the right-click contextual menu
§ Select [Edit>Copy] from the main menu
§ Press CTRL+C on the keyboard
Select an empty slot.
Select the paste command using either of the menus or CTRL+V.

Note:

These commands do not function with multiple selections.

Deleting from Slots
Modular processor blocks can easily be removed from a configuration without affecting any other
aspect of the signal flow.
1.
2.

To delete a processor block:
Select the processor block with a single left mouse click.
Select the delete command using one of the following methods.
§ Use the right-click contextual menu.
§ Select [Edit>Delete] from the main menu.
§ Press the DELETE key.
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Linking
You can link multiple processor blocks of the same type in order to control them as one. Changes made in
the processor parameter window of any block in a link group will simultaneously change the settings of
every other block in that group. There are a few activities, however, that will still function independently on
linked blocks:
§ Delete, Copy, Cut and Paste,
§ Moving the block to a different slot or channel strip,
§ Naming the processor parameter window.
Fixed processors at the same stage of the gain structure can also be grouped, which will synchronize the
level controls for all of the grouped channels. For example, you can group two input channel gain blocks in
order to control them as a stereo pair. You can also link all output gain blocks, in order to adjust the output
channel levels overall from a single control.

Note:

Only processors of precisely the same type can be linked.

Creating a Link Group
When you first create a link group, all of the processors in that group will synchronize to the same
settings. If you have already specified settings for one of the processors prior to creating the link
group, you can designate it as the source when you first create the group, causing the other processor
blocks to inherit those settings. Alternately, if you would like to discard any previous processor
settings, you can select the factory default settings as the initial source. After the link group is created,
changes to settings of any of the linked blocks will affect all blocks in that group.
To create a link group:
1.

CTRL+Click to select multiple processor blocks.

2.

Select [Processor >Link>New Link Group] from the
main menu, or [Link>New Link Group] from the rightclick contextual menu.

3.

The Create Link Group dialog appears, as pictured to
the right in figure 14.

4.

Enter a two-character name for the link group.

5.

Choose a source for the initial link group settings.

6.

Click [OK] to accept the settings.

The two-character link group name appears both on the
processor block in the signal flow diagram, and in the link
indicator at the lower right-hand corner of the processor
parameter window, as illustrated in the following table.
Processor Parameter Window

Note:

Figure 14 − Link Group Dialog

Signal Flow Diagram

Processors can only belong to one link group at a time.
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Adding to a Link Group
Processor blocks can be added to an existing link group, if they are the exact same type of processor
and they are currently unlinked. Any processor added to a link group will inherit the group’s current
settings.
To add blocks to an existing link group:
1.

Click to select a processor block, or CTRL+Click to
select multiple blocks.

2.

Select [Processor>Link>Add To] from the main menu,
or [Link>Add To] from the right-click contextual menu.

3.

The Add to Link group dialog appears, as shown in figure
15. It lists only the link groups that contain a processor
identical to the one in the selected block.

4.

Select a link group.

5.

Click [OK].

Figure 15 − Add to Link Group Dialog

Unlinking Processor Blocks
Processor blocks can be removed from a link group without affecting other linked blocks. You can also
dissolve a link group by unlinking all the blocks in the group.
1.
2.

To remove blocks from an existing link group:
Click to select a processor block, or CTRL+Click to select multiple blocks.
Select [Processor>Link>Unlink] from the main menu, or the right-click contextual menu.

Note:

A link group must contain at least two processor blocks. Removing all but one
block from a link group will dissolve the group completely.

Bypassing
From the main window, you can bypass any modular
processor block. This lets you evaluate the signal path while
temporarily excluding a processor. Bypassed blocks in the
signal flow diagram include a yellow flag, as shown in figure
16.
1.
2.

To toggle bypass on or off:
Figure 16 − Bypassed Processor Block
Click to select a processor block, or CTRL+Click to select
multiple blocks.
Activate bypass with any of the following methods:
§ Press CTRL+B on the keyboard.
§ Select [Processor>Bypass Selected] from the main menu.
§ Use the right-click contextual menu.

Note:

Crossovers and splitters cannot be bypassed.
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SAVING A CONFIGURATION _______________________________
After you create a configuration, you can save it to either the computer as a scene file, or to the device as a
preset, depending on whether or not you are connected to the P4800. When you are in Live Mode, the
configuration you are creating is written directly to the current live preset. You can save it to the PC at any time
by clicking the [Save As] button on the control bar of the main window.

Scene Files
You can design an entire library of signal flow configurations with the System Processor software without being
connected to the device. Configurations saved to PC are scene files that can be later recalled, revised, and
then sent to the device as presets. Scene files are saved with a “.scn” file extension.

Saving a New Scene
If you are not connected to the device, you will be saving each new signal flow configuration to the
computer as a scene file.
1.
2.
3.
4.
5.

To save a new scene file:
In the main window, select [File>Save As Scene File] from the main menu or click the
[Save As] button on the control bar.
The Save Scene As dialog will appear.
Navigate to the drive and directory location for the new file.
Type in a file name and, optionally, a description.
Click [Save].

Note:

Scene files for other Shure digital signal processor devices, such as the DFR11EQ
or DP11, share the same .SCN file extension. It is best to save scene files for
different device types in separate directories to help distinguish among them.

Using the Description Field
The optional description field entry helps to identify scene files when opening them. The scene file
description is copied over to the preset description when you store the scene file to the device as a
preset.

Revising Scene Files
When you make changes to an existing scene file, you can either save it with a different file name, or
overwrite the previous version.
To revise a scene file:
1. In the main window, select [File>Open Scene File] from the main menu or click the
[Open] button on the control bar.
2. The Open Scene dialog will appear.
3. Navigate to the drive and directory location of the scene file you wish to open.
4. Click on the file to select it, then click the [Open] button.
5. Make the necessary changes.
6. Select [File>Save As Scene] from the main menu or click the [Save As] button on the control bar.
7. The Save Scene As dialog will appear.
8. Click on the original file name to select it, then click [Save].
9. A dialog box will appear that prompts you to verify that you want to overwrite the previous scene file.
10. Click [Yes] to overwrite the file.
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Preset Management
The System Processor can store at least sixteen and up to one hundred and twenty-eight presets in its device
memory, depending upon their complexity. Once presets are stored in the device, they can be renamed,
deleted, or backed up as a set.

Store a Preset in the Device
When you are connected to the device, in Design Mode you can store new signal flow configurations
to the device as presets, or open existing scene files and store them to the device.
To store a preset in the device:
1.

In the main window, select [File>Store As Preset] from the
main menu, or if you are in Design Mode you can also click
the [Store Preset] button on the control bar.

2.

The Select Devices dialog will appear, as pictured on the
right in figure 17.

3.

Select from the list of available devices and click [Connect].
Figure 17 − Select Devices Dialog

1.
2.
3.
4.

5.

The Store Preset dialog will appear, as
pictured on the left in figure 18.
Type in a preset name of no more than
fifteen characters.
Type in a preset number, or accept
the default.
Type in a description (optional), which
will help identify the contents of the
preset for further operations.
Click [Store].

Figure 18 − Store Preset Dialog
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Rename a Preset
After you have stored a preset in the device, you can change its name and description in
Live Mode.
To rename a preset:
1.

Click on the [Live Mode] button on the control bar.

2.

Select the preset you wish to rename from the pull-down
menu in the information box on the control bar.

3.

The main window will enter preview mode for the
selected preset.

4.

Click the [Load] button on the control bar to make it the
live preset.

5.

Click once anywhere in the information box.

6.

The Rename Preset dialog will appear, as pictured to the
right in figure 19.

7.

Type in the new name and/or description.

8.

Click [OK].

Figure 19 − Rename Preset Dialog

Delete a Preset
From Design Mode you can delete presets from the device that are no longer in use.
To delete a preset:
1.

Click on the [Design Mode] button
on the control bar.

2.

Select [File>Delete Preset].

3.

The Select Devices dialog will
appear.

4.

Select from the list of available
devices and click [Connect].

5.

The Delete Preset dialog will
appear, as pictured on the right
in figure 20.

6.

Select the preset you wish to
delete, or SHIFT+Click to select
multiple presets.

7.

Click [Delete].

Figure 20 − Delete Preset Dialog

Note:

The current live preset will not be available for deletion. If you need to delete this
preset, you must first select a different live preset.
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Device Backup
You can backup all presets stored in the device to a single archive, and restore this backup set to the device at a
later date. You must be in Design Mode to perform or restore a backup.
To backup all presets in the device:
1.

Click on the [Design Mode] button on the
control bar.

2.

Select [File>Backup Device] from the
main menu.

3. The Select Devices dialog will appear.
4.

Select from the list of available devices and
click [Connect].

5.

The Backup Device dialog appears, as
pictured on the right in figure 21.

6.

Click [Backup Device].

7.

The Save Backup As dialog appears, as
pictured below on the right in figure 22.

8.

Navigate to the correct directory and type in a
file name.

9.

Click [Save].

Figure 21 − Backup Device Dialog

To restore a backup to the device:
1.

Select [File>Restore Device] from the main menu.

2.

The Open Backup dialog will appear, similar to the
Save Backup dialog pictured on the right in figure 22.

3.

Navigate to the correct directory and select the
appropriate backup set from the list.

4.

Click [Open].

5.

The Select Devices dialog will appear.

6.

Select from the list of available devices and click
[Connect]. This sends the backup set to the device.

Figure 22 − Save Backup As Dialog
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PROCESSOR FEATURES__________________________________
This section describes software features that are common among many of the processor parameter windows.
For features specific to the individual processors, refer to the Fixed Processors section on page 34 and the
Modular Processors section on page 40.

Faders
Faders appear in many of the processor windows, as in the example pictured below in figure 23, below on the
right. They allow you to adjust gain with an up-down movement of the mouse, just as you would slide a fader
on an actual mixer console. You can also specify the level numerically by typing a number in the value box.
First select the fader, then adjust the level using any of the methods described below.

Selecting
Select a fader by positioning the mouse cursor over the fader knob and clicking on it with the left
mouse button, or by clicking in the value box located below the fader strip. The fader knob will highlight
to indicate that it has been selected. If the window contains multiple faders, you can move between
them from left to right using the TAB key, and move backward from right to left using SHIFT+TAB.
Fader knob in selection
Fader knob deselected

Adjusting the Level
To adjust the level with the mouse:
§ Click and hold on the fader knob to drag it up and down.
§ Click on the fader strip at the level that you wish to set.
§ Right-click on the fader knob to set the level to 0dB.
To adjust the level with a single keystroke:
1.

Select the fader you want to adjust.

2.

Use any of the following keys to adjust the value.
Keystroke

Result

Up Arrow

Increase 0.5 dB

Down Arrow

Decrease 0.5 dB

Page Up

Increase 3 dB

Page Down

Decrease 3 dB

Spacebar

Sets value to 0dB

Figure 23 − Standard Controls

Value Box
The value box allows you to specify the level within a tenth of a decibel. All faders have a value box
associated with them. In most processor windows, each fader has a value box located directly below it.
The two exceptions are the GEQ10 and GEQ30 windows, which have only one gain value box for the
entire set of faders. In this instance, first select the knob of the fader you wish to adjust, then enter a
value in the box.
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Spin Buttons
Spin buttons appear to the left of all value boxes. They provide a convenient way to increment the
setting without having to type in a specific value.
To increment the value with spin buttons:
§ Click on the up or down spin button to increment the level +/–0.5 dB.
§ Click and hold on a spin button to scroll the level up or down. As you hold longer,
the scrolling will accelerate.

Saving and Recalling Settings
The settings in any processor parameter window can be saved to a computer file and recalled the next
time you need a similar setup in the same type of processor. This allows you to create custom or
installation-specific default settings for commonly used processors. If you are going to save many
settings to PC, it is a good idea to create a directory specifically for processor settings, or for a specific
installation.
1.
2.
3.
4.
5.

To save processor settings:
Double-click the processor block to open its processor parameter window.
Select [File>Save Settings] from the menu or press CTRL+S on the keyboard.
Type in a file name.
Click [Save].
The application will add a file extension that indicates the type of processor that created it.

1.
2.
3.
4.

To recall processor settings:
Double-click the processor block to open its processor parameter window.
Select [File>Recall Settings] from the menu or press CTRL+R on the keyboard.
Select the appropriate settings file.
Click [Open].

Note:

You can only recall settings to the identical type of processor that created the
setting file.

Naming Processor Windows
The parameter window for each modular processor block in the signal flow diagram can be given a
unique name, which is useful when multiple windows are open simultaneously. The default processor
window titles include both the name of the general processor type and the label of the channel strip on
which they are placed.
To distinguish between similar processors; you can customize the window name to reflect the
particular function or settings of the processor. The new window name will appear both in the title bar
of the processor parameter window and on the Windows task bar when the parameter window is
minimized.
1.
2.
3.
4.

To rename a processor parameter window:
Double-click the block to open its processor parameter window.
Select [Options>Name] from the menu.
Type the new name, up to fifteen characters.
Click [OK].

Note:

This will change the name of the processor parameter window only. The title of
the processor block does not change in the signal flow diagram.
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Snapshots
The snapshot feature is available in any processor parameter window that has a response curve or transfer
curve graph. It allows you to capture an image of the current curve, then display it for reference purposes as
you revise the processor settings. The processor remembers this snapshot until you take a new one in the
same processor window, or quit the application.
The following response curve examples are taken from the parameter window of a five-band parametric EQ
with cut and shelf filters (PEQ5+CS).
To use the snapshot feature:
1.

Click the [TAKE] button,
as shown in figure 24.
This captures the current
response or transfer curve.

2.

Click the [SHOW] button.
This displays the
snapshot behind
the current curve.
Figure 24 − Taking a Snapshot

The button
appears lighted in green when the
snapshot is displayed.
3.

Change
the
processor
settings. As you reshape the
curve, you will be able to
compare it to the snapshot of
the previous curve showing in
the background, as shown in
figure 25.

Figure 25 − Reshaping the Response Curve

4.

Click the [SHOW] button
again to toggle the
snapshot off and on, as
pictured on the right in
figure 26.

Figure 26 − Hiding the Snapshot

Note:

When you show the snapshot before you have changed any processor settings,
it will be hidden behind the current curve. The snapshot will show up as soon as
you reshape the curve with different settings.
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FIXED PROCESSORS _____________________________________
These processors make up the three different stages of the System Processor’s Gain Structure (see page 16
for more on this topic). They are referred to as fixed processors because the gain and mix blocks in the signal
flow diagram cannot be moved or deleted.

Input Gain
The Input Gain processor contains individual controls for all four input channels. Double-click on the gain block
at the left end of any input channel strip to open this window, as pictured below in figure 27.

Figure 27 − Input Gain Window

Scaling Options
Use these buttons to scale each input channel to match the output level of the equipment in line before
the System Processor. Click to toggle between -10dBV or +4dBu levels. The default setting is +4dBu.
+4dBu selected
-10dBV selected

Signal Polarity
Click this button to invert the polarity of the signal entering the input channel strip. The default setting is
normal polarity.
Normal polarity
Inverse polarity
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Gain Controls
Use these controls to adjust the signal level of each input channel. First select the fader knob, then
adjust the level with the mouse, arrow keys, or specify a level in the value box. For complete
instructions on their operation, see the Faders section on page 31. The adjustment range is from
+30dB to –30dB, and the default setting is 0dB, or unity gain.

Note:

The input gain controls adjust the level of the signal after it has already been
digitally converted within the System Processor. Signal levels exceeding the
input threshold of the System Processor must be adjusted externally.

Channel Mute
Click this button to mute the channel. The default setting is inactive.
Mute activated
Mute inactive

Channel Label
Use this text box to customize the input channel strip label in the signal flow diagram. The default
setting is “Untitled In” for each input channel number.

Link Indicator
This displays the link status of the input channel. Any setting you change on a linked channel will be
changed for all other channels in the same link group. For a complete explanation of linking and link
groups, see the Linking section on page 25.
Channel linked
Channel not linked
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Matrix Mixer
The Matrix Mixer processor contains controls for mix point connections in the signal flow diagram, organized
under separate window tabs for each output mix point. Double-click on any mix block to open this window, as
pictured below in figure 28.

Figure 28 − Matrix Mixer Window

Window Tabs
The window opens focused on the output pane for the mix
block that you double-clicked. Click on any tab to access
controls for a different output mix point.
The window tabs correspond to the output mix
points in the signal flow diagram. If you are
using crossovers, the tab titles will reflect the
range of output strips spanned by each
crossover, as shown in figure 29.

Figure 29 − Mixer Tabs with Crossovers
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Input Controls
Click this button to activate a connection from the corresponding input channel mix point. Controls for
inactive inputs appear faded out. The default setting is inactive.

Input Selector
Click this button to activate a connection from the corresponding input channel mix point. Controls for
inactive inputs appear faded out. The default setting is inactive.
Connection Activated
Connection Inactive

Signal Polarity
Click this button to invert the polarity of the signal. The default setting is normal polarity.
Normal polarity
Inverse polarity

Gain Controls
Use these controls to adjust the signal level of each channel. First select the fader knob, then adjust
the level with the mouse, arrow keys, or specify a level in the value box. For complete instructions on
their operation, see Faders section on page 31. The adjustment range is from +10dB to –infinitydB,
and the default setting is 0dB, or unity gain.

Channel Mute
Click this button to mute the channel. The default setting is inactive.
Mute activated
Mute inactive

Channel Label
This displays the channel label you have specified in the Input Gain or Output Gain windows.

Link Indicator
This displays the link status of the output control of the current window tab. Any setting you change on
a linked output control will change on all the other mixer outputs in the same link group. As you switch
window tabs, this indicator will change with the link status of the current tab. For a complete
explanation of linking and link groups, see the Linking section on page 25.

Note:

When you link mix blocks, you are linking only the output controls from the Matrix
Mixer. The input controls remain independent.
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Output Gain
The Output Gain processor contains individual controls for all eight output channels. Double-click on the gain
block at the right end of any output channel strip to open this window, as pictured below in figure 30.

Figure 30 − Output Gain Window

Scaling Options
Use these buttons to scale each input channel to match the output level of the equipment in line before
the System Processor. Click to toggle between -10dBV or +4dBu levels. The default setting is +4dBu.
+4dBu selected
-10dBV selected

Signal Polarity
Click this button to invert the polarity of the output signal. The default setting is normal polarity.
Normal polarity
Inverse polarity
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Gain Controls
Use these controls to adjust the signal level of each output channel. First select the fader knob, then
adjust the level with the mouse, arrow keys, or specify a level in the value box. For complete
instructions on their operation, see Faders section on page 31. The adjustment range is from +30dB to
–30dB, and the default setting is 0dB, or unity gain.

Output Pad
Click this button to attenuate the signal output by –20dB. The default setting is inactive.
Pad activated
Pad inactive

Channel Mute
Click this button to mute the channel. The default setting is inactive.
Mute activated
Mute inactive

Channel Label
Use this text box to customize the output channel strip label in the signal flow diagram. The default
setting is “Untitled Out” for each output channel number.

Link Indicator
This displays the link status of the output channel. Any setting you change on a linked channel will be
changed for all other channels in the same link group. For a complete explanation of linking and link
groups, see the Linking section on page 25.
Channel linked
Channel not linked
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MODULAR PROCESSORS _________________________________
This section describes the features and controls specific to each of the processor block parameter windows. In
some cases, several processor blocks share nearly identical controls, such as the downward expander and
gate. In these instances, the processors are described as a group, using a single parameter window as the
illustrated example. Control settings that are individual to one of the processors in the group are so noted in the
description of those controls.

Automatic Gain Control/Leveler (AGC)
The AGC/Leveler creates a more consistent volume level for program material that tends to fade and swell. It
acts as a combination upward expander and compressor, increasing the gain of the input signal when the level
is too low, and reducing it when the level is too high.

§

Block Name

Description

AGC

Automatic Gain Control

Figure 31 − AGC Window

Function
Use the leveler in situations where it is desirable to maintain a constant volume level, such as for
podium and lectern microphones where the speaker's proximity to the microphone varies. The leveler
compensates for quiet levels by gradually raising the gain. If the speaker then talks loudly into the
microphone, the AGC will gradually reduce the gain.

Parameter Window Features
This section describes the features and parameter controls specific to the Automatic Gain Control
processor, as pictured above in figure 31.
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Transfer Curve Graph
The transfer curve graph displays the threshold level and compression ratio settings as graphical
elements that you can position with the mouse. The resulting transfer curve represents the change in
the signal output level.

Maximum Gain Line
The greatest amount that the AGC will boost the signal is +12dB, as indicated by the maximum gain
line. This prevents undesirable noise modulation or acoustic feedback problems that may arise from
excessively boosting low-level signals. The maximum gain line only appears in the transfer curve
graph when the combination of the threshold, hinge, and ratio settings result in the AGC imposing the
+12dB limit.

Transfer Curve Meter
When you are in Live Mode, this meter depicts the signal's input level and relative output level, so you
can monitor the processor's effect on the current program material. This feature can be toggled off and
on by selecting the [Options>Transfer Curve Meter] menu option. Its default status is on.

Note:

You may experience reduced software performance if you have a large number of meters
active overall in the System Processor software. You can selectively turn off either the
transfer curve meter or the gain reduction meter, or both, from the [Options] menu.

Threshold Slider
The position of the threshold slider corresponds to the setting in the threshold control. You can drag
this slider with the mouse, left and right along the top edge of the transfer curve graph, to change the
threshold setting.

Ratio Slider
The position of the ratio slider corresponds to the setting in the ratio control. You can drag this slider
with the mouse, up and down along the right-hand edge of the transfer curve graph, to change the
ratio setting.

Hinge Slider
The position of the hinge slider corresponds to the setting in the hinge control. You can drag this slider
with the mouse, left and right along the bottom edge of the transfer curve graph, to change the hinge
setting.

Gain Reduction Meter
This meter indicates the total gain increase or reduction you are achieving on the input signal with the
current processor settings. This feature can be toggled off and on by selecting the [Options>Gain
Reduction Meter] menu option. Its default status is on.

Gain Controls
Use the gain controls to adjust the input and output gain levels. The range of available gain values is
between –12dB and +12dB in 0.5dB increments, with 0dB as the default value. You can change the
value using the conventions explained in the Faders section on page 31.

Threshold Exceeded Indicator
This indicator appears lighted in yellow when the input signal to the processor block exceeds the
specified threshold.
Signal level has exceeded the threshold
Signal level has not reached the threshold
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Threshold
This indicates the level the signal gain must reach before the processor increases it.
Signal levels below the threshold are passed through the processor at unity gain. You
can change the value by clicking on the spin buttons, typing in a specific value, or using
the threshold slider above the transfer curve graph. The available range of values is from –60VU to
+20VU in 0.5VU increments, with a default value of 0VU.

Ratio
This indicates the amount of gain reduction you are achieving at the output of the
processor, relative to the input level that exceeds the hinge. A setting of 4:1, for example,
means that a 4dB increase in the level of the program material results in a 1dB increase in
the output level from the processor. You can change the value by clicking on the spin buttons, typing in a
specific value, or using the ratio slider on the right-hand side of the transfer curve graph. The range of
available values is from 1:1 to 10:1, in increments of a tenth, with a default value of 2:1.

Attack
This indicates how much time the processor waits before responding to rising or falling
input levels, once the input level exceeds the threshold, The available values are from
0.2s to 3s, with a default value of 2 seconds.

Decay
This indicates how much time the processor waits before returning to unity gain, once
the input level increases or decreases closer to the hinge setting. The range of available
values is from 0.5s to 5s, with a default value of 5 seconds.

Hinge
The hinge setting is the target output level of the AGC. It is a pivot point that determines
whether the input level is raised or lowered. Signal levels below the hinge (but above the
threshold) will be raised and levels above the hinge will be lowered. You can change the
value by clicking on the spin buttons, typing in a specific value, or using the hinge slider below the
transfer curve graph. The available range of values is from –60VU to +20VU in 0.5VU increments, with
a default value of 0VU.

Default
Click this button to reset the processor to its system default settings.

Bypass
Click to pass signal through without the effect of the processor. When bypass is active, the button
appears lighted in red. The default setting is inactive.
Bypass active
Bypass inactive

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the
[Take] button. You can then display it in the background for comparison by clicking the
[Show] button. The [Show] button appears lighted in green when the snapshot is
displayed. For a more in-depth description of the snapshot feature, see the Snapshots
section on page 33.
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Compressor/Limiter
Compressors and limiters reduce the output level of the signal relative to the input level, once the input level
exceeds a certain threshold. The System Processor provides the following types of compressors and limiters:
Block Name

Description

§ COMP
§ SFT COMP

Compressor

§ LIM
§ SFT LIM

Limiter

§
§
§
§

ST COMP
ST SFT COMP
ST LIM
ST SFT LIM

§ PEAK LIM

Soft Knee Compressor
Soft Knee Limiter

Same as above; for use on two channels that comprise a
stereo pair.

Peak Stop (Look Ahead) Limiter

Figure 32 − SFT LIM Window

Function
Use the compressor to scale the output of a signal so it is suitable for equipment with a narrower
dynamic range, such as an amplifier, tape deck, or loudspeaker. Use the limiter to protect the system
against sudden bursts of loudness that could potentially damage loudspeakers. By delaying the signal
1 ms, the Peak Stop Limiter has an attack time of 0 to provide even more control over transient
sounds. The compressor and limiter function similarly, however the limiter is typically set for a faster
attack time and a higher compression ratio.
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The following types of processors are available in both limiters and compressors.

§

Soft Knee – These processors provides a gradual transition from uncompressed signal to
compressed signal. These processors consume a higher percentage of total DSP than
those without the soft knee option.

§

Stereo – These processors allows you to preserve a stereo image by placing two blocks
that function as a single processor on two different channels. Both processor channels react
with identical gain reduction when the input to either channel exceeds the threshold setting.
These processors consume a higher percentage of total DSP than mono processors.

Parameter Window Features
This section explains the features and parameter controls of compressors and limiters using the SFT LIM
as the example, as pictured in figure 32 on the previous page. All the processors covered in this section
are very similar in operation. Any differences between their features and functionality are noted where
applicable.

Transfer Curve Graph
The transfer curve graph displays the threshold level and compression ratio settings as graphical
elements that you can position with the mouse. The resulting transfer curve represents the change in
the signal output level.

Transfer Curve Meter
When you are in Live Mode, this meter depicts the signal's input level and relative output level, so you
can monitor the processor's effect on the current program material. This feature can be toggled off and
on by selecting the [Options>Transfer Curve Meter] menu option. Its default status is on.

Note:

You may experience reduced software performance if you have a large number
of meters active overall in the System Processor software. You can selectively
turn off either the transfer curve meter or the gain reduction meter, or both, from
the [Options] menu.

Threshold Slider
The position of the threshold slider corresponds to the setting in the threshold control. You can drag
this slider with the mouse, left and right along the top edge of the transfer curve graph, to change the
threshold setting.

Ratio Slider
The position of the ratio slider corresponds to the setting in the ratio control. You can drag this slider
with the mouse, up and down along the right-hand edge of the transfer curve graph, to change the
ratio setting.

Gain Reduction Meter
This meter indicates the total gain reduction you are achieving on the input signal with the current
processor settings. This feature can be toggled off and on by selecting the [Options>Gain Reduction
Meter] menu option. Its default status is on.

Gain Controls
Use the gain controls to adjust the input and output gain levels. The range of available gain values is
between –12dB and +12dB in 0.5dB increments, with 0dB as the default value. You can change the
value using the conventions explained in the Faders section on page 31.
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Threshold Exceeded Indicator
This indicator appears lighted in yellow when the input signal to the processor block exceeds the
specified threshold.
Signal level has exceeded the threshold
Signal level has not reached the threshold

Threshold
This indicates the gain level the signal must reach before the processor begins
compressing it. You can change the value by clicking on the spin buttons, typing in a
specific value, or using the threshold slider above the transfer curve graph. The
available range of values is from –60VU to +20VU in 0.5VU increments, with a default value of 0VU.

Ratio
This indicates the amount of gain reduction you are achieving at the output of the
processor, relative to the input level. A setting of 4:1, for example, means that a 4dB
increase in the level of the program material results in a 1dB increase in the output level
from the processor. You can change the value by clicking on the spin buttons, typing in a specific
value, or using the ratio slider on the right-hand side of the transfer curve graph. The range of available
values is from 1:1 to INF:1, in increments of a tenth, with a default value of 2:1 for the compressors
and 10:1 for the limiters. The Peak Stop Limited has a fixed ratio of INF:1.

Attack
This indicates how much time the processor waits before starting to reduce the gain,
once the input signal level passes the threshold. The range of available values is from
1ms to 200ms, with a default value of 5ms for the compressors and 2ms for the limiters.
The Peak Stop Limiter has a fixed attack time of 0 ms.

Decay
This indicates how much time the processor waits before returning to unity gain, once
the input signal level drops below the threshold. The range of available values is from
50ms to 1000ms, with a default value of 100ms for the compressors and 50ms for the
limiters.

Knee
In "Soft" processors, this control displays a pull-down list from which you can select either soft knee or
hard knee compression. The default setting is soft. In the standard compressors and limiters, this
control is disabled.
Soft Knee
Processor

Select "Soft" or "Hard" from the pull- down list.

Standard
Processor

Control is disabled.

Default
Click this button to reset the processor to its system default settings.
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Bypass
Click to pass signal through without the effect of the processor. When bypass is active, the button
appears lighted in red. The default setting is inactive. When bypass is active in the Peak Stop Limier,
the 1 ms of delay is not bypassed.
Bypass active
Bypass inactive

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the
[Take] button and then display it in the background for comparison by clicking the
[Show] button. The [Show] button appears lighted in green when the snapshot is
displayed. For a more in-depth description of the snapshot feature, see the Snapshots
section on page 33.

Soft Knee Processors
The following examples illustrate the difference between the hard knee and soft knee compression
settings. All other settings in these examples remain identical.
A soft knee setting, pictured at left in figure 33, is useful when you are
working with high compression ratios. The soft knee gradually increases the
compression ratio from 1:1, at approximately 12dB below the threshold, up to
the specified ratio, at approximately 20dB above the
threshold. This gradual increase in ratio makes the
compression less obtrusive than with the hard knee.

Figure 33 − Soft Knee
Compression

The hard knee setting, pictured at right in figure 34,
immediately activates compression at the ratio you
have specified, once the signal level exceeds the
threshold. This setting is especially useful in a limiter,
because it will keep sudden peaks from exceeding the
threshold without affecting signal below the threshold.
Figure 34 − Hard
Knee Compression

Note:

If the situation calls for a hard knee setting, you can conserve DSP
by using a standard processor instead of a soft knee processor.

Stereo Processors
The stereo processors have the same features and functionality as their mono counterparts, and
include some additional features.

§

Changes to settings of either of the two processor channels will be applied to the other
channel as well.

§

Both processor channels react with identical gain reduction when the input to either channel
exceeds the threshold setting.

§

Dual transfer curve meters display the channel A input level in red and the channel B input
level in blue.

§

Meter selectors allow you to alternately view the transfer curve meter for channel A, channel
B, both channels, or neither.

§

There is a threshold exceeded indicator for both the A and B channels.
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Crossover/Splitter
Crossovers and splitters divide one input signal into multiple output signals. Crossovers divide the frequency
spectrum of the input signal into multiple bands, then output each band to a separate channel. Splitters simply
distribute the input signal across multiple output channels.

§
§
§
§

Block Name

Description

XOVER 2
XOVER 3
XOVER 4
XOVER 5

2-way Crossover
3-way Crossover
4-way Crossover
5-way Crossover

§
§
§
§

Block Name

Description

SPLIT 2
SPLIT 3
SPLIT 4
SPLIT 5

2-way Splitter
3-way Splitter
4-way Splitter
5-way Splitter

Figure 35 − XOVER 4 Window

Function
Use the crossover to divide the frequency range of the input signal with multiple band pass filters, then
distribute each frequency band to a separate output for different types of speakers. Use the splitter to
send the same signal to several different outputs. There is no parameter window for the splitter
processors, as they simply distribute the signal at unity gain with no additional processing. Crossovers
and splitters are for output processing only, and cannot be placed on input channel strips. See the
Adding Processors: Crossovers and Splitters section on page 22 for more information on placing
crossover and splitter blocks in the signal flow diagram.

Parameter Window Features
This section explains the features and parameter controls of the crossover using the XOVER 4 as the
example, as pictured above in figure 35. The features of the other crossovers are identical, aside from
the number of the pass band filters.
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Response Plotter
This area of the window graphically displays the pass band filters and crossover points, which you can
manipulate by clicking and dragging with the mouse.

Pass Bands
Each band has a corner handle on either side that you can drag left and right to
individually adjust the upper and lower corner frequencies. There is also a gain handle
in the center of each band that you can drag up and down to adjust the output level of
the pass band. When you select a handle, it fills with a colored ball to indicate that it is the active control.
The upper and lower filter slopes are set with the pass band controls in the lower section of the window.

Crossover Handle
This handle indicates the frequency of the crossover point between two pass
bands. You can drag it left and right to simultaneously adjust the corner
frequencies of the intersecting filter slopes. When you select a crossover
handle, it turns green to indicate that it is the active control, and the
corresponding corner handles fill to indicate they are selected. The corner
handles maintain their positions relative to each other as you slide the
crossover handle.

Output Channel Labels
These labels at the head of the columns of pass band controls are color-coded to match the
corresponding band pass curves in the response plotter. They indicate to which output channel each
pass band is routed.

Set and Show Gains/Normalize Plot
Toggle between these two buttons to
alternately display the pass bands at
their actual gain levels, and display them
normalized. The default setting is [Set
and Show Gains on Plot].
When the gain levels of pass bands are
significantly different, the crossover point
appears offset from its actual location, as
illustrated in figure 36 on the right. Use the
normalize plot display mode when you
need to see the precise location of the
crossover point, as illustrated in figure 37,
below right.
•

Click the [Set and Show Gains on
Plot] button to display and adjust pass
band gain levels. With this setting,
filter levels are reflected in the
response plotter and the gain handles
are visible on the pass bands.

•

Click the [Normalize Plot] button to
display the pass bands at unity gain in
the response plotter. Actual gain
settings are not affected by this setting.

Figure 36 – Display Pass Band Gain Levels

Figure 37 – Display Normalized Plot
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Default
Click this button to reset the processor to its system default settings.

Mute
Click this button to mute the output channel. When mute is active, the button appears lighted in red
The default setting is inactive.
Mute activated
Mute inactive

Polarity
Click this button to invert the polarity of the signal entering the output channel strip. The default setting
is normal polarity.
Normal polarity
Inverse polarity

Low Corner Freq
This indicates the frequency setting of the lower corner of the pass band. The range of
values available depends on the setting of the upper corner frequency, as corner
frequencies cannot overlap. You can change the value by clicking on the spin buttons, using the
keyboard controls, or typing in a specific value. The default values for the various pass bands are
listed below for each type of crossover.
Xover Type

2-way

3-way

4-way

5-way

Band 1

OUT

OUT

OUT

OUT

Band 2

2.0 kHz

200 Hz

150 Hz

60 Hz

Band 3

−

2.0 kHz

1.5 kHz

150 Hz

Band 4

−

−

5.0 kHz

1.0 kHz

Band 5

−

−

−

6.0 kHz

Low Filter Type/Upper Filter Type
This indicates the slope of the corresponding pass band corner. Select a value from the
pull-down menu, as listed below. The default setting is 24dB/oct Linkwitz-Riley.
Abbreviation

Description

6 Butt

6dB/oct Butterworth

12 Butt

12dB/oct Butterworth

12 Bess

12dB/oct Bessel

12 L-R

12dB/oct Linkwitz-Riley

18 Butt

18dB/oct Butterworth

24 Butt

24dB/oct Butterworth

24 Bess

24dB/oct Bessel

24 L-R

24dB/oct Linkwitz-Riley
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Note:

Using a 12dB/oct filter type in adjacent bands will create a notch at the crossover
frequency if the outputs are summed. When aligning loudspeakers, take care
that the acoustic response does not display this notch. If necessary, use the
polarity button to invert the polarity of one of the bands.

Upper Corner Freq
This indicates the frequency setting of the upper corner of the pass band. The range of
values available depends on the setting of the lower corner frequency, as corner
frequencies cannot overlap. You can change the value by clicking on the spin buttons, using the
keyboard controls, or typing in a specific value. The default values for the various pass bands are
listed below for each type of crossover.
Xover Type

2-way

3-way

4-way

5-way

Band 1

2.0 kHz

200 Hz

150 Hz

60 Hz

Band 2

OUT

2.0 kHz

1.5 kHz

150 Hz

Band 3

−

OUT

5.0 kHz

1.0 kHz

Band 4

−

−

OUT

6.0 kHz

Band 5

−

−

−

OUT

Gain
This indicates the current gain setting of the pass band filter. The range of available gain values is
between –18dB and +12dB in 0.5dB increments, with a default setting of 0dB. You can change the
value using the conventions described in the Faders section on page 31.

Keyboard Controls
You can use keyboard controls to make fine adjustments to the handle positions in the response
plotter. Click to select a handle, then use the following shortcuts.
Keystroke

←
→

Crossover and
Corner Handles

Gain Handle

Decreases frequency
by one screen pixel
Increases frequency
by one screen pixel

−

↑

−

↓
SHIFT with ←
SHIFT with →

−
Decreases frequency
by 1/3 octave
Increases frequency
by 1/3 octave

SHIFT with ↑
or PAGE UP
SHIFT with ↓
or PAGE DOWN
SPACEBAR
or right mouse click

Note:

−
Increases gain
by 0.5 dB
Decreases gain
by 0.5 dB
−
−

−

Increases gain
by 3 dB

−

Decreases gain
by 3 dB

−

Sets gain to 0 dB

Nudging the frequency by one screen pixel changes the value by approximately
1/100 of an octave, or 1%.
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Cut and Shelf Filters
The cut and shelf filters are a type of parametric EQ that boost or cut the overall high and low frequency
characteristics of a system, and roll off the high and low end of the frequency spectrum.
Block Name

§

Description

CUT/SHELF High and Low Cut/High and Low Shelf Filters

Figure 38 − CUT/SHELF Window

Function
Use this processor when you need to combine cut filters with broad-spectrum high and low-end room
equalization. The high and low cut filters feature a wide variety of slope options, between –6dB/oct and
−24dB/oct. You can also specify the corner slope of the shelf filters, either 6dB/oct or 12dB/oct.

Parameter Window Features
This section describes the features and parameter controls specific to the Cut and Shelf processor, as
pictured above in figure 38.

Response Plotter
This area of the parameter window graphically displays the cut and shelf filter handles, which you can
manipulate by clicking and dragging with the mouse. When you initially open the parameter window,
the filter handles appear in their system default positions at the extreme high and low boundaries of
the frequency spectrum. Click on a handle to view its response curve and adjust settings.
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Response Graph
This curve is a graphical representation of the combined results of the filter handles in the response
plotter.

Note:

The curve does not reflect the accumulated affect of multiple processor
blocks in the signal path.

Cut Filters
Cut filters appear as handles at the bottom edge of the response plotter, with dashed vertical lines
extending along their center frequencies. Their default frequency setting is "OUT," and the default type
is 6dB/Butterworth.

Shelf Filters
The high and low cut/shelf filters appear along a horizontal axis in the center of the response plotter.
Their default frequency setting is "OUT," and the default type is 6dB/oct.

Frequency
This indicates the frequency of the selected filter point. You can change the
value by clicking on the spin buttons, using keyboard controls, or by entering a
specific value. The frequency range is from 25Hz to 20kHz, with "OUT" as the default setting.

Type
This indicates the slope type for the selected filter. The values
available in the pull-down menu vary for cut and shelf filters, as listed
below.
Shelf

Cut

6 dB/Octave*
12 dB/Octave

6
12
12
12

dB/Butterworth*
dB/Butterworth
dB/Bessel
dB/Linkwitz-Riley

18
24
24
24

dB/Butterworth
dB/Butterworth
dB/Bessel
dB/Linkwitz-Riley

* Indicates default setting

Gain
This indicates the current gain setting of the selected shelf filter. The range of
available gain values is between –18dB and +18dB in 0.5dB increments, with a
default setting of 0dB. You can change the value using the conventions described in the Faders
section on page 31. When you are working with a cut filter this control is disabled and displays the
word “CUT.”

Clear
Click this button to return filter settings to their defaults. It opens the Clear Options dialog
(figure 48 on page 68), which provides you with the option to clear all filter settings, or to
clear only selected filter settings.

Bypass
Click to pass signal through without the effect of the processor. When bypass is active, the button
appears lighted in red. The default setting is inactive.
Bypass active
Bypass inactive
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Snapshot
This feature allows you to freeze an image of the current response curve by clicking
the [Take] button and then display it in the background for comparison by clicking the
[Show] button. The [Show] button appears lighted in green when the snapshot is
displayed. Refer to the Snapshots section on page 33.

Importing ASCII Files
See page 74 for a description of how to import data into the graph, using SIA Smaart
and Gold Line TEF into the response graph.

Fine Tuning Parameters
You can precisely adjust parameters for the selected filter using any of the following methods:
§ Enter a number into any of the parameter boxes
§ Using the spin buttons (or drop down box) next to the parameter boxes
§ Using the keyboard controls

Keyboard Controls
You can use the following keyboard controls to make fine adjustments to the currently selected filter.
Keystroke

←
→
↑
↓
SHIFT with ←
SHIFT with →
SHIFT with ↑
or PAGE UP
SHIFT with ↓
or PAGE DOWN
SPACEBAR
or right mouse click
DELETE

Note:

Result
Decreases frequency by one screen pixel
Increases frequency by one screen pixel
Increases gain by 0.5 dB
Decreases gain by 0.5 dB
Decreases frequency by 1/3 octave
Increases frequency by 1/3 octave
Increases gain 3 dB
Decreases gain by 3 dB
Sets gain to 0 dB
Resets selected filter(s) to default settings

Nudging the frequency by one screen pixel changes the value by approximately
1/100 of an octave, or 1%.

Copy and Paste
Filter handle settings can be copied and pasted between Cut and Shelf processor windows.
1.

2.
3.
4.

To copy and paste filters:
Click to select a single filter, or select multiple filters using one of the following methods:
§ CTRL+Click.
§ Use the [Edit>Select All] menu command.
Select the [Edit>Copy] menu command.
Open the Cut and Shelf processor window where you wish to paste filter settings.
Select the [Edit>Paste] menu command.

Note:

When filters are part of a multiple selection, they are highlighted in pink and their
parameter settings are locked. To de-select from a multiple selection, click on
any control in the parameter window, or on a filter outside the selection area.
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Delay
The delay processor temporarily stores the signal in delay memory, then passes it on after the specified interval
has elapsed. The System Processor provides the following types of delay:

§
§
§
§

Block Name

Description

DLY5ms
DLY150ms
DLY500ms
DLY2s

5 Millisecond Maximum Delay
150 Millisecond Maximum Delay
500 Millisecond Maximum Delay
2 Second Maximum Delay

Figure 39 − Delay Window

Function
Use delay to align the sound output from different speakers so that it arrives simultaneously at the
audience members. You can also use delay to correct phase cancellation problems between installed
loudspeakers. Delay can be calculated with time, distance, and air temperature increments.

Note:

Each type of delay processor block will consume the maximum amount of delay
memory indicated in the block name, regardless of how much you are actually using.
In order to conserve System Processor resources, you should select the delay
processor with the nearest maximum to your required delay time.

Parameter Window Features
This section explains the features of the delay processors using the DLY150 as the example, as
pictured above in figure 39. The features of the other delays are identical, aside from the maximum
delay time available.

Units
Use this control to specify whether parameters should be
in English or Metric units. The default value is English.

Time
Use this control to specify the delay in milliseconds. The range of values is
between 0ms and the maximum delay time of the processor block, in this
case 150ms. The default value is 0ms.
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Distance
Use this control to specify the delay by distance. The range of values
varies, depending on the maximum delay time, but the default is always
zero. Select the appropriate unit of measure with the radio buttons to the
right of the control. When English units are selected, you can choose between inches or feet. When
Metric units are selected, distance is indicated in meters. The default value is inches.

Air Temperature
Use this control when you are setting the delay by
distance, since the speed of sound is affected by air
temperature. The range of values is from -13°F to 122°F, or -25°C to 50°C. When English units are
selected, air temperature is indicated in Fahrenheit. When Metric units are selected, air temperature is
indicated in Celsius. The default value is Fahrenheit.

Bypass
Click to pass signal through without the effect of the processor. When bypass is active, the button
appears lighted in red. The default setting is inactive.
Bypass active
Bypass inactive

Clear
Click this button to reset the processor to its system default settings.
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Digital Feedback Reducer (DFR)
The DFR uses Shure's patented Adaptive Notch Filter algorithm to automatically detect feedback and deploy
narrow-band notch filters. The System Processor provides the following types of DFR:
Block Name Description

§
§

DFR5
DFR10

5 Band Digital Feedback Reducer
10 Band Digital Feedback Reducer

Figure 40 − DFR10 Window

Function
Use the DFR as the initial processor on any input channel that receives signal from a live microphone
where feedback is problematic. Each time it detects feedback, the DFR activates a dynamic filter. It
begins by inserting a −3 dB, 1/10-octave notch filter at the feedback frequency. It then increases the
filter depth in 3 dB increments, up to −18 dB, until the feedback stops. You can also allocate fixed
filters at specific room nodes. When the DFR detects feedback at the frequency of a fixed filter, it
deepens that notch with a dynamic filter.

Parameter Window Features
This section explains the features and parameter controls of the digital feedback reducer using the
DFR10 as the example, as pictured above in figure 40. The features of the DFR5 are identical, aside
from the number of notch filters available.

Response Graph
This curve is a graphical representation of the combined results of the processor's active notch filters
(highlighted in yellow).

Note:

The curve does not reflect the accumulated affect of multiple processor
blocks in the signal path.

Frequency
This indicates the frequency of the selected filter. You can change the value
by clicking on the spin buttons, using keyboard controls, or by entering a
specific value. The frequency range is from 25Hz to 20kHz, with "OUT" as the default setting.

SHURE P4800 System Processor Software Guide

Page 56 of 108

Modular Processors
Depth
This indicates the gain reduction of the selected filter. The range of available
gain values is between 0db and –18dB in 0.5dB increments, with a default
setting of 0dB.

Type
This indicates the bandwidth type of the selected filter. Select High Q or Low
Q from the pull-down menu. Low Q is the default value.

Feedback Filters
The feedback filters controls appear as a row of LED-style indicators. You
can specify the number of fixed versus dynamic filters by sliding the red
brackets left and right with the mouse. Active filters are indicated in yellow and
appear in the Response Graph. Refer to the Filter Allocation section on page
59 for further explanation.
FIXED

These filters remain at their current frequencies regardless of
newly detected feedback.

DYNAMIC

These filters are automatically deployed by the DFR when it
detects feedback.

Lock
Click this button to prevent both the deployment of new filters and the deepening of existing filters. Use this option to
keep the DFR from deploying filters for program material that contains desired feedback or sounds closely
resembling feedback (such as guitar effects, synthesized tones, or pipe organ).
Lock active
Lock inactive

Clear
Click this button to return filter settings to their defaults. It opens the Clear Options dialog
(Figure 44 on page 60), which provides you with the option to clear all filter settings, or to
clear only selected filter settings.

Bypass
Click to pass signal through without the effect of the processor. When bypass is active, the button
appears lighted in red. The default setting is inactive.
Bypass active
Bypass inactive

Snapshot
This feature allows you to freeze an image of the current response curve by clicking
the [Take] button and then display it in the background for comparison by clicking the
[Show] button. The [Show] button appears lighted in green when the snapshot is
displayed. For a more in-depth description of the snapshot feature, see the Snapshots
section on page 33.
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Basic DFR Setup
There are two basic ways in which to set-up the DFR to reduce feedback; the Ring-Out Method and
the Insurance Policy Method, as described below. Each is valid for different situations.

Note:

§

§

1.
2.
3.
4.

5.

The DFR (or any other notch filter system) helps reduce feedback, but cannot
entirely eliminate it. In a typical system, you reach a point of "diminishing returns"
after 4 to 8 notch filters are set. You can expect a 6 to 9 dB improvement of gainbefore-feedback in a typical system. To achieve greater sound system
performance, you may need to improve your sound environment.

Ring Out Method − With this method, you use the DFR as a preemptive measure against
feedback for input channels that operate near the feedback point and need an extra
margin of stability. Using this method, you raise the input channel's gain beyond its
normal setting to deliberately make the system feed back. The DFR will then set the
proper filters. Then, when you reduce the input gain to an appropriate level, the system is
stable and useable.
Insurance Policy Method − With this method, you use the DFR as added insurance
against unexpected feedback in an otherwise stable system. Simply placed the DFR
processor in the signal path, without defining any settings. This method is used for
systems which already have sufficient gain-before-feedback, but need protection from
occasional feedback occurrences due to non-stationary microphones or user-adjustable
gain controls.

To ring out the system:
Remove any active filters by clicking the [Clear] button.
Open all mics.
Monitor the DFR window while slowly increasing the system gain. As the DFR detects acoustic
feedback, it deploys new filters, indicated in the DFR window as yellow dots.
Continue to increase gain 3 to 6 dB beyond the gain level at which you will operate the system, or
until 4 to 8 filters have been deployed. Lower the gain 3 to 6 dB to the desired setting to stabilize
the system.
Allocate the deployed filters as "fixed" (see Fixed and Dynamic Filter Allocation on the following
page). The remaining dynamic filters will deploy as needed when the system is in use.

Note:

You can copy the fixed filters to a PEQ block to allow for more dynamic filters in
the DFR window.

Hold Mode
By default, the DFR saves the state of all of its filters during a preset change or power cycle. However,
you can configure the DFR to clear certain filters when a power cycle or preset change occurs. After
setting all of the filters you want to be permanent, enable the hold mode. Any filters deployed after hold
mode has been selected will be cleared upon a preset change or power cycle.
1.
2.

To enable hold mode:
Ring out the system as described in the previous section.
Select the [Options>Hold Mode] menu command.
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Filter Allocation
The DFR uses two methods of filter allocation, as described below.
§ Fixed – You can manually specify these notch positions or designate them as fixed after the
DFR has automatically deployed a dynamic filter. They remain stationary regardless of newly
detected feedback frequencies. However, if the DFR detects additional feedback at that
position, a dynamic filter will deploy to increase the notch depth.
§ Dynamic – The notch position and depth are completely automatic. A dynamic notch will
deepen in response to increased feedback, and as new feedback frequencies are detected,
the DFR re-deploys the dynamic filters from oldest to newest.
The DFR allows you to select how many of the total number of notch filters will remain fixed, and how
many will be dynamically allocated as feedback is detected. Use a greater number of fixed filters on
input channels for stationary microphones. In this instance, the room acoustics define the dominant
feedback frequencies, which do not change appreciably. Use a greater number of the dynamic filters
on input channels for wireless or hand-held microphones. In this situation, feedback frequencies
change drastically as the microphone user wanders the room or sound stage.
You can designate the number of fixed versus dynamic
filters using either of the two techniques explained below:

1.
2.
3.
4.
1.
2.
3.

To use the Fixed/Dynamic Filter Options dialog:
Select [Options>Fixed filters allocation] from the DFR
window's menu.
The Fixed/Dynamic Filter Options dialog appears,
as pictured to the right in figure 41.
Type the number of fixed filters you wish to allocate.
The number of dynamic filters adjusts accordingly.
Click [OK].

Figure 41 − Fixed/Dynamic Filter Options

To change filter allocation with the mouse:
Position the cursor between the red brackets as indicated
to the right in figure 42.
The cursor changes to the horizontal resize symbol:
Click and drag left to increase the number of dynamic filters,
or right to increase the number of fixed filters.

High Q Filters vs. Low Q Filters
The DFR offers two width options for notch filters, as pictured
below in figure 43. High Q filters remain narrow as filter depth
increases, attenuating the minimum amount of signal. This
maintains high sound quality appropriate for most
applications, including music.

Figure 42 −Changing Filter
Allocations with the Mouse

With the low Q setting, the filter notch maintains its shape
as it deepens, resulting in a wider range of frequency
attenuation. This setting creates greater system stability,
but with slightly diminished sound quality. This setting is
appropriate for speech-only applications.

§

To change the setting for an existing filter, click to
select the filter and use the [Type]
pull-down menu.

§

Use the [Options] menu to select the high or low
Q setting for all new dynamic filters as they are deployed.
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Adding, Modifying, and Removing Filters
1.
2.
3.

To manually deploy or modify a fixed filter notch:
Click to select an active fixed filter (highlighted in yellow) or, to activate a new filter, select the filter
to the immediate right of the last active filter.
Adjust the frequency, depth, and type as necessary.
You will see the changes reflected in the response graph.

Note:

1.
2.
3.
4.

You can only select an active filter or the next adjacent inactive filter, from left to right.

To remove all active notch filters:
Click the [Clear] button.
The Clear Options dialog appears, as in figure 44.
Select [Clear All Filters] and click [OK].
This removes all notch filters, and flattens the response graph.
– OR –

1.
2.
3.

Select the [Edit>Select All] menu command.
All deployed filters will be highlighted in pink to indicate
they are selected.
Press the DELETE key.

1.
2.

To remove specific notch filters
Click on a filter indicator to select it, or CTRL+Click to select multiple filters.
Press the DELETE key – OR –

Figure 44 − Clear Options Dialog

Click the [Clear] button to open the Clear Options dialog and select the [Clear One Filter] option,
which also applies to a multiple filter selection.

Copy and Paste
Filter notches can be copied and pasted between DFR processor windows.
1.

2.
3.
4.

To copy and paste filters:
Click to select a single filter, or select multiple filters using one of the following methods:
§ CTRL+Click.
§ Use the [Edit>Select All] menu command.
Select the [Edit>Copy] menu command.
Open the DFR processor window where you wish to paste filter settings.
Select the [Edit>Paste] menu command.

Note:

When filters are part of a multiple selection, they are highlighted in pink and their
parameter settings are locked. To de-select from a multiple selection, click on
any control in the parameter window, or on a filter outside the selection area.

The System Processor software also gives you the unique ability to copy and paste any active filters
from the DFR window to a Parametric Equalizer (PEQ or PEQ +CS) window. By moving fixed filters to
a PEQ window, you can allocate more dynamic filters in the DFR block.

Note:

DFR filters copied to a PEQ block may not exactly match the original filter, rather,
they use a bandwidth that most closely approximates the original filter.
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Gate/Downward Expander
The gate and downward expander reduce the output level of the signal, relative to the input level, once the
input level drops below a certain threshold.
Block Name

§
§

Description

DOWN EXP Downward Expander
GATE
Gate

Figure 45 − DOWN EXP Window

Function
Use these processors to reduce or eliminate unwanted background noise. The gate mutes the input
signal once it falls below a certain threshold. The downward expander gradually reduces the gain once
the input signal falls below a certain threshold, providing more subtle gain reduction than the gate. The
gate is ideal when you need to eliminate low-level noise that otherwise would distract from the program
material. Select the downward expander to somewhat reduce background noise in situations where
gating the signal completely off would disrupt the program.

Parameter Window Features
This section explains the features and parameter controls of the downward expander and gate using the
DOWN EXP as the example, as pictured above in figure 45. These two processors are very similar in
operation. Any differences between their features and functionality are noted where applicable.

Transfer Curve Graph
The transfer curve graph displays the threshold level and compression ratio settings as graphical
elements that you can position with the mouse. The resulting transfer curve represents the change in
the signal output level.
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Transfer Curve Meter
When you are in Live Mode, this meter depicts the signal's input level and relative output level, so you
can monitor the processor's effect on the current program material. This feature can be toggled off and
on by selecting the [Options>Transfer Curve Meter] menu option. Its default status is on.

Note:

You may experience reduced software performance if you have a large number of
meters active in the System Processor software. You can selectively turn off either the
transfer curve meter or the gain reduction meter, or both, from the [Options] menu.

Threshold Slider
The position of the threshold slider corresponds to the setting in the threshold control. You can drag
this slider with the mouse, left and right along the top edge of the transfer curve graph, to change the
threshold setting.

Ratio Slider
The position of the ratio slider corresponds to the setting in the ratio control. To change the ratio
setting, drag this slider left or right along the bottom edge of the transfer curve graph, using the mouse.

Gain Reduction Meter
This meter indicates the total gain increase or reduction you are achieving on the input signal with the
current processor settings. This feature can be toggled off and on by selecting the [Options>Gain
Reduction Meter] menu option. Its default status is on.

Gain Controls
Use the gain controls to adjust the input and output gain levels. The range of available gain values is
between –12dB and +12dB in 0.5dB increments, with 0dB as the default value. You can change the
value using the conventions explained in the Faders section on page 31.

Threshold Exceeded Indicator
Signal level has exceeded the threshold
Signal level has not reached the threshold

This indicator appears lighted in yellow when
the input signal to the processor block exceeds
the specified threshold.

Threshold
This indicates the level below which the input signal gain must fall before the processor reduces it. You can
change the value by clicking on the spin buttons, typing in a specific value, or using the
threshold slider at the top edge of the transfer curve graph. The available range of values is
from –80.0VU to 0VU in 0.5VU increments, with a default value of –65.0VU for the gate
and –40.0VU for the downward expander.

Ratio
This indicates the amount of gain reduction at the processor output, relative to the input level. A ratio of
4:1, for example, means a 1dB decrease in program level results in a 4dB decrease in processor
output level. You can change the value by clicking on the spin buttons, typing in a
specific value, or using the ratio slider on the bottom edge of the transfer curve graph.
The range of available values is from 1:1 to INF:1, in increments of 1/10th, with a
default value of INF:1 for the gate and 4:1 for the downward expander.
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Attack
This indicates how much time the processor waits after the input signal gain exceeds the
threshold before returning to unity gain. The available values are from 1ms to 200ms,
with a default value of 2ms for the gate and 20ms for the downward expander.

Decay
This indicates how much time the processor takes to reach the specified gain reduction.
You can change the value by clicking on the spin buttons or typing in a specific value.
The range of available values is from 50ms to 1000s, with a default value of 100ms for
the gate and 50ms for the downward expander.

Hold
This indicates how much time the processor waits after the input signal gain drops
below the threshold to begin reducing gain. You can change the value by clicking on
the spin buttons or typing in a specific value. The available range of values is from 0ms
to 500ms, with a default value of 0ms.

Default
Click this button to reset the processor to its system default settings.

Bypass
Click to pass signal through without the effect of the processor. When bypass is active, the button
appears lighted in red. The default setting is inactive.
Bypass active
Bypass inactive

Snapshot
This feature allows you to freeze an image of the current response curve by clicking
the [Take] button. You can then display it in the background for comparison by clicking
the [Show] button. The [Show] button appears lighted in green when the snapshot is
displayed. For a more in-depth description of the snapshot feature, see the Snapshots
section on page 33.
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Graphic Equalizer
Graphic equalizers distribute a fixed set of broadband, constant-Q filters across the frequency spectrum, each
with individual boost/cut controls. The System Processor provides the following types of graphic equalizers:
Block Name Description

§
§

GEQ10
GEQ30

10 Band Graphic Equalizer
30 Band Graphic Equalizer

Figure 46 − GEQ10 Window

Function
Use this processor for convenient broadband room equalization. The overall bandwidth of the
processor and the bandwidth of the individual filters depend on the type of graphic EQ you select. The
GEQ10 has 10 one-octave filters between 31.5Hz and 16kHz, while the GEQ30 has 30 1/3-octave
filters between 25Hz and 20kHz. GEQ10 is shown in figure 46 above.

Parameter Window Features
This section explains the features and parameter controls of the graphic EQ, using GEQ10 as an
example. GEQ30 is identical, except for the number of bands and overall frequency range.

Frequency Band Faders
You can set the frequency band faders by dragging the knob up or down with the mouse or by clicking on
the scale at the level that you would like to set. You can cut or boost any band between –18dB and +12dB
in 0.5dB increments. For more information on setting faders, see the Faders section on page 31.

Response Graph
This curve is a graphical representation of the results of your frequency band settings, as well as the
type of filter Q you have selected.

Note:

The curve does not reflect the cumulative affect of multiple processor blocks
in the signal path.
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Frequency
This indicates the current frequency band that you are adjusting. You can select
a different frequency band by clicking on the spin buttons. The default selection
is the lowest frequency band.

Gain
This indicates the current gain setting of the selected frequency band. The
range of available gain values is between –18dB and +12dB in 0.5dB
increments, with a default setting of 0dB. You can change the value using the
conventions explained in the Faders section on page 31.

Filter Q Type
This indicates the type of filter Q that is set for all the frequency bands.
Use the pull-down list to change the value. The default value is combining.
Combining

Averages the slope between the frequency bands, creating an overall
smooth equalization curve.

Non-Combining

Isolates the result of each frequency band control, providing more
independent gain adjustment.

Bypass
Click to toggle the bypass switch on and off. When bypass is active, the button appears lighted in red.
The default setting is inactive.
Bypass active
Bypass inactive

Flat
Click this button to set the gain of all frequency bands to zero.

Snapshot
This feature allows you to freeze an image of the current response curve by clicking
the [Take] button. You can then display it in the background for comparison by clicking
the [Show] button. The [Show] button appears lighted in green when the snapshot is
displayed. For a more in-depth description of the snapshot feature, see the Snapshots
section on page 33.

ASCII Files
Refer to page 74 for a description of how to import data into the response graph using
SIA Smaart and Gold Line TEF.

Copy and Paste
You can use the [Edit] menu to copy and paste frequency band settings between graphic equalizers of
the same type.

Note:

You cannot paste settings between the GEQ10 and GEQ30 processors.
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Parametric Equalizer
Parametric equalizers allow you to specify the placement, type and bandwidth of multiple filters anywhere in the
frequency spectrum between 25Hz and 20kHz. The System Processor provides the following types of
parametric equalizers:
Block Name

Description

§
§
§
§

PEQ3
PEQ5
PEQ7
PEQ10

These processors provide peak/notch filters only.

§
§
§
§

PEQ3+CS
PEQ5+CS
PEQ7+CS
PEQ10+CS

These processors provide peak/notch filters, plus a low cut
or shelf filter and a high cut or shelf filter.

Figure 47 − PEQ Window

Function
Use this processor for precise equalization of room response without unnecessarily affecting
neighboring frequencies. Select a parametric equalizer based on the number of frequency bands you
need to adjust, and whether or not you would like to include cut or shelf filters in the processor. You
can conserve DSP by selecting the fewest filters that fit your needs.

Note:

The number in the block name reflects the maximum number of peak/notch filters
available for that processor.
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Parameter Window Features
This section explains the features and parameter controls of the parametric equalizer processors using
the PEQ3+CS as the example, as pictured in figure 47 on the previous page. The features of the other
parametric equalizers vary only in the number of bands and the availability of the cut/shelf filters.

Response Plotter
This area of the parameter window is where you place and adjust parametric filters. It graphically displays
peak/notch filters as points and cut/shelf filters as square handles. When you initially open the processor
window, the response plotter contains no filter points and, if applicable, the cut/shelf filters appear in their
default positions. Click on a filter point or handle to view its response curve and adjust settings. Refer to
the Working with Filters section on page 69 for instructions on how to add filter points.

Response Graph
This curve is a graphical representation of the combined results of the filter points and handles in the
response plotter.

Note:

The curve does not reflect the accumulated affect of multiple processor
blocks in the signal path.

Filter Points
Peak/Notch filters appear in the response plotter as filter points with adjustable bandwidth controls on
either side. Click once on a filter point to make it the current selection, then adjust its settings with the
mouse, keyboard controls or by using the value boxes. When you select a filter point, its response
curve is displayed in green across the response plotter, relative to zero.

Cut/Shelf Filters
The high and low cut/shelf filters appear as square handles. Each handle can be used as either a cut
or a shelf filter, depending on its vertical position in the response plotter. When you first open the
parameter window, the handles operate as high and low shelf filters, with a default setting of 0db at
20kHz and 25Hz, respectively. They become cut filters when you drag them to the bottom edge of the
response plotter.

Frequency
This indicates the frequency of the selected filter point. You can change the
value by clicking on the spin buttons, using keyboard controls, or by typing a
specific value. The frequency range is from 25Hz to 20kHz, with a default value
of 1kHz when you add a new filter point.
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Width /Slope/Type
This control changes depending on the type of filter currently in selection, as listed below. For a cut
filter, you have two slopes to choose from the pull-down menu. When a peak/notch filter is selected,
you can use the pull-down menu of preset values, or specify the width within a thousandth of an octave
by typing in a value. There are no settings in this control for shelf filters.
Filter Type

Appearance

Peak/Notch

Range of Values
From 1/70 oct through 4 oct, default value: 2/3 oct
From 100.99 Q through 0.27 Q, default value: 2.14 Q

Cut

–6 dB/oct & –12 dB/oct, default value: –6 dB/oct

Shelf

None

Gain
This indicates the current gain setting of the selected filter. The range of
available gain values is between –18dB and +18dB in 0.5dB increments, with a
default setting of 0dB. When you are working with a cut filter this control is
disabled and displays the word “CUT.”

New
Click this button to add a new peak/notch filter to the response plotter. When you first open
the window, the number below the button indicates the quantity of filter points that are
available for the parametric EQ you have selected, and it decreases incrementally as you
add filter points to the response plotter. When you have reached the maximum number of filters for the
processor, the button is disabled.

Clear
Click this button to clear filter settings. It opens the Clear Options dialog, which provides
you with the option to clear all filter settings, or to clear only selected filter points from the
response plotter. Refer to the Working with Filters section on the following page for
more information.

Bypass
Click to toggle the bypass switch on and off. When bypass is active, the button appears lighted in red.
The default setting is inactive.
Bypass active
Bypass inactive

Snapshot
This feature allows you to freeze an image of the current response curve by clicking
the [Take] button. You can then display it in the background for comparison by clicking
the [Show] button. The [Show] button appears lighted in green when the snapshot is
displayed. For a more in-depth description of the snapshot feature, see the Snapshots
section on page 33.

ASCII Files
Refer to page 74 for a description of how to import data into the response graph using
SIA Smaart and Gold Line TEF.

SHURE P4800 System Processor Software Guide

Page 68 of 108

Modular Processors

Working with Filters
When you initially open the parameter window of a parametric EQ, there are no peak/notch filters in
the response plotter. Add filter points as you need them, up to the maximum number available for the
selected processor block.

1.
2.

1.
2.
3.

4.
5.

To add a new filter point:
Click the [New] button.
A filter point appears at 0dB with a default frequency value
of 1kHz and a bandwidth of 2/3 octave.
To remove all filter points:
Click the [Clear] button or select [Edit>Clear Filters] from the
Figure 48 − Clear Options Dialog
parameter window menu bar.
The Clear Options dialog appears, as pictured to the right in
figure 48.
Select [Clear All Filters] and click [OK]. This removes all filter points from the response plotter and
returns the cut/shelf filters to the default settings.
To remove specific filter points:
Click on a filter point to select it, or CTRL+Click to select multiple filters.
Press the DELETE key – OR – Click the [Clear] button to open the Clear Options dialog and select
the [Clear One Filter] option, which also applies to a multiple filter selection.

Note:

You cannot remove cut/shelf filter handles, however you can return them to
their default settings by using [Clear] or DELETE.

Adjusting Filters in the Response Plotter
You can change filter settings by dragging the filter points and handles with the mouse.
1.
2.
3.

To adjust gain and frequency:
Position the cursor over the center of the filter point or handle.
The cursor changes to the move symbol:
Click and drag the filter left or right to adjust frequency, and up or down to adjust gain.

Note:

1.
2.
3.

The response plotter displays a curve only for the selected filter. The
combined curve is displayed in the response graph.

To adjust filter point bandwidth:
Position the cursor over either of the filter’s bandwidth control points.
The cursor changes to the horizontal resize symbol:
Click and drag the control point left or right to set the bandwidth.

Fine Tuning Parameters
You can precisely adjust parameters for the selected filter point using any of the following methods:
§
§
§

Enter a number into any of the parameter boxes
Using the spin buttons (or drop down box) next to the parameter boxes
Using the keyboard controls
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Keyboard Controls
You can use the following keyboard controls to make fine adjustments to the currently selected filter.
Keystroke

Result

←
→

Increases frequency by one screen pixel

↑

Increases gain by 0.5 dB

↓

Decreases gain by 0.5 dB

SHIFT with ←

Decreases frequency by 1/3 octave

SHIFT with →

Increases frequency by 1/3 octave

CTRL with ←

Decreases the bandwidth of a filter point by small increments

CTRL with →

Increases the bandwidth of a filter point by small increments

SHIFT with ↑
or PAGE UP

Increases gain 3 dB

SHIFT with ↓
or PAGE DOWN
SPACEBAR
or right mouse click

Note:

Decreases frequency by one screen pixel

Decreases gain by 3 dB
Sets gain to 0 dB

Nudging the frequency by one pixel changes the value by approximately 1/100 of
an octave, or 1%.

Copy, Cut and Paste
Filter points can be copied, cut and pasted between parametric EQ windows, given the following
considerations:
§ There are a sufficient number of available filter points in the parameter window where you
are pasting.
§ Cut/Shelf filter settings can only be copied and pasted between PEQ+CS processors.

Note:

1.

2.
3.
4.

The Cut command is not available for cut/shelf filter handles.

To copy and paste filters:
Click to select a single filter, or select multiple filters using one of the following methods:
§ CTRL+Click.
§ Use the [Edit>Select All] menu command.
Select the [Edit>Copy] menu command.
Open the parameter window of the parametric EQ where you wish to paste filter settings.
Select the [Edit>Paste] menu command.

Note:

When filters are part of a multiple selection, they are highlighted in pink and their
parameter settings are locked. To de-select from a multiple selection, click on
any control in the parameter window, or on a filter outside the selection area.
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Ducker
The ducker provides an easy way to use the P4800 in an audio system that requires paging. When a paging
signal is present, the ducker attenuates or "ducks" other signals.

§

Block Name

Description

DUCK

Ducker

Function
Drag and drop the ducker onto an input strip to designate that input as the paging signal. When the
paging signal exceeds the threshold, the ducker attenuates all other signals present at each matrix
mixer point to which it is routed. Route the paging signal using the matrix mixer or the "Paging
Channels" checkboxes in the ducker's parameter window.
Note: The ducker can only be placed on an input channel strip. Place no more than one ducker on
each input channel strip.
To prevent extraneous noise from the paging input from being audible, place a gate ahead of the
Ducker in the signal flow diagram.
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Parameter Window Features
Transfer Curve Graph
The transfer curve graph displays the threshold level as a graphical element that you can position with
the mouse.

Transfer Curve Meter
In the Live Mode, this meter depicts the paging signal's input level, so you can set the threshold above
ambient noise. This feature can be toggled off and on by selecting the [Options>Transfer Curve] menu
option. Its default status is on.

Note:

Software performance may be reduced if a large number of meters are active.
You can turn off the threshold meter or the gain reduction meter, or both, from
the [Options] menu.

Threshold Slider
The position of the threshold slider corresponds to the setting in the threshold control. Use the mouse
to drag this slider left or right along the top edge of the threshold graph. The threshold level will change
accordingly.

Gain Reduction Meter
This meter indicates the total gain reduction you are achieving on the ducked signals with the current
processor settings. This feature can be toggled off and on by selecting the [Options>Gain Reduction
Meter] menu option. Its default status is on.

Threshold Exceeded Indicator
Signal level has exceeded the threshold
Signal level has not reached the threshold

This indicator is lighted in yellow when the
input signal to the processor block exceeds the
specified threshold.

Attenuation
This controls the amount of gain reduction applied to the ducked signals when the paging signal
exceeds the threshold. You can change this value by clicking on the spin buttons or by typing in a
specific value ranging 1 dB to -INF.

Threshold
This controls the gain level the paging signal must reach before the processor attenuates the ducked
signals. You can change the value by clicking on the spin buttons or by typing in a
specific value ranging from +20 dB to –60 dB.

SHURE P4800 System Processor Software Guide

Page 72 of 108

Modular Processors

Attack
This controls the amount of time it takes the processor to fully reduce the ducked signals’
gain, once the paging signal crosses the threshold. You can change the attack time by
clicking on the spin buttons or by typing in a specific value. The range of available values is
from 1 to 5000 ms.

Hold
This controls the amount of time the processor continues to attenuate the ducked
signals once the paging signal has dropped back below the threshold. You can change
this value by clicking on the spin buttons or typing in a specific value. The range of
available values is from 1 ms to 10,000 ms.

Release
This controls the amount of time it takes the processor to return the ducked signals to
their previous level once the hold time has passed. You can change this value by
clicking on the spin buttons or by typing in a specific value. The range of available
values is from 1 ms to 10,000 ms.

Default
Click this button to reset the processor to its system default settings.

Bypass
Click to this button to pass signal through the processor block without altering it. When the bypass
function is active, the button is lighted red. The default setting is inactive.
Bypass active
Bypass inactive

Paging Channels
Check the box next to each output to which you want to route the
paging signal. This is identical to routing the input with the ducker to
output mix points in the signal flow diagram.
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Importing ASCII Files from SIA-Smaart or Gold Line TEF
Software
Graphic equalizer, parametric equalizer, and cut/shelf windows can display data contained in an ASCII file
exported from either an SIA-Smaart transfer function measurement or a Gold Line TEF TDS measurement.

Function
Use the ASCII file import feature to display frequency vs. magnitude information measured in Smaart or
TEF. By inverting the data, you can use the display as a visual guide when setting EQ parameters. The
display only shows amplitude values for frequencies contained in the file; it does not interpolate a line
between actual measured points. Consequently, there may be empty space in the display, particularly at
low frequencies.
The ASCII import feature is compatible with files generated from:
§ Transfer function measurements in SIA-Smaart Pro (versions 2/x and 3.x), and SIA
SmaartLive™.
§ TDS measurements in all versions of TEF™ TDS software for Windows and DOS.

Saving Smaart Files in ASCII Format
To export a measurement using Smaart software, measure in Transfer Function Mode. Then select
[File>ASCII Save] from within the Smaart application.

Saving TEF Files in ASCII Format
To export a measurement using TEF TDS software, proceed as follows:
1. Select [File>Save] from within the TEF TDS application.
2. Enter file information, and click "Save." In the "Save TDS File" window, select "ASCII" as the
file type.
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Parameter Window Features
Import
Click this button to import ASCII files from either Smaart or TEF. When the [Open File]
window appears, select the file you wish to import. The data from the imported file will
be displayed in the Response Graph. When a TEF TDS file is imported, the average
magnitude value is plotted at 0 dB and all other magnitude values are biased accordingly. By default,
Smaart transfer function files are not offset. Magnitudes are centered around the 0 dB axis, just as
they are in Smaart.

Refresh
Click this button to re-import the last imported file. If you take a new measurement in
Smaart or TEF and save it with the same file name, overwriting the previous file, you
can click the [Refresh] button to import the new measurement without having to go through the open
file dialog.
Note: The [Refresh] button DOES NOT change the bias of the original file. If the average magnitude
value of a TEF TDS file changes, the refreshed display will still be biased around the original average
value. Also, any offset you add to the file using the [Offset] text box will not change when you click on
[Refresh].

Show
Click on this button to show or hide the imported file display. The [Show] button is lighted
in green when a file is displayed.

Offset
This indicates the amount by which the display is offset from the actual amplitude values
contained in the ASCII file. By default, a TEF TDS measurement will be offset by its
average amplitude to center it around the 0 dB axis in the Response Graph.

Invert
Click on this box to invert the displayed data around the x-axis. You may then use the
inverted display as a visual guide for EQ parameters. [Invert] is selected by default.

Help
Click on this button to access on-line help with importing Smaart and TEF ASCII files.
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CONTROL PINS__________________________________________
The pin connectors on the back of the System Processor provide options for external control of the device and
logic output. You can connect external control hardware to the control input pins, such as an AMX, Crestron, or a
custom wall panel. This type of simple hardware interface provides end users with a means to switch between
presets, mute channels, or adjust gain without the need for a computer. The logic output can be connected to
LED's, relays, or third-party logic hardware if the installation requires external devices or status displays to
respond to the System Processor's active preset and mute status.

External Control Overview
External device control is established at three different levels, as illustrated below in figure 49. In this example,
external control input is configured for switching between three presets, adjusting overall system output gain
with a potentiometer, and muting an input channel with a locking switch. The logic output is configured to
trigger external devices depending
on which preset is active, and
indicate the mute status of an
input channel with an LED.

Figure 49 − The Three Levels of External Device Control

To establish external device control:
1.

External Connections
When the device is initially installed, determine what type of control input and logic output the
installation calls for, and wire the block connector terminals accordingly. Refer to the Control Pin
Connections section of the Hardware Installation Guide for instructions and wiring diagrams.

2.

Pin Configuration
Use the Control Pins window of the software interface to configure the System Processor to
properly recognize the hardware control connections. This configuration is stored as a global
setting in the device, and can also be saved as a computer file. Refer to the Pin Configuration
Section on page 80 for instructions.

3.

Processor Mapping
Once the device is configured to recognize external control, assign input and output channels to
the control connections. Use the processor mapping section of the Control Pins window. Each
preset or scene file stores a unique processor map. Refer to the Processor Mapping section.
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The Control Pins Window
The Control Pins window is an interface for both configuring control pins globally at the device level, and
assigning processors to controllers specifically for each preset. Access this window by selecting the
[Devices>Control Pins Configuration] menu command from the main window.

Configuration Views
The Control Pins window has two configuration views: Control In and Logic Out. To switch between the
two views, click on either the [Control In] or [Control Out] text or on the corresponding pin connectors,
depending on which set of pins you wish to configure. Figure 50 shows the [Control In] view.

Figure 50 -- Control Pins Window: "Control In" View

CONTROL IN
Use this view to configure and map the control input pins to perform any of the following functions via
external hardware:
§ Switch between presets stored in the device.
§ Mute and un-mute channels.
§ Adjust gain levels.

LOGIC OUT
Use this view to configure and map the logic output pins to indicate any of the following conditions to
external displays or devices:
§ The preset number of the active preset.
§ The mute status of any input or output channel.

Preset Encoding Parameter Settings
These parameter boxes appear next to the [Control In] and [Logic Out] text in the upper part of the
Control Pins window. The combined settings in these boxes dictate the configuration of the preset
control block. Enter the number of presets first, then select an encoding type.
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Note:

There are restrictions as to which encoding types may be used in combination
with the number of presets that you specify. Refer to the Preset Encoding Types
section on page 81 for more information.

# Presets
Specify here the number of presets in the device that will be addressed by external
hardware in the given configuration view. The range of values is from 0 to 128, with a
default value of zero.

Encoding Type
Specify here the type of encoding you will be using for preset control. The
available values vary depending on the number you have specified in the
[# Presets] value box, as explained further in the Encoding Types section
below. The default value is "None."

More Info Button
Click this button to access help topics on the Control Pins window.

Pin Configuration Section
Use this section of the window to configure the System Processor to properly recognize any control pin
connections that are wired to external hardware. When you first open the window, all the connections
are disabled and there is no differentiation between the function of the pins. Once you define how
many pins will be used for preset control, if any, the display distributes those connections to a preset
control block and any remaining pins can be allocated for processor control.

Note:

You must be in Design Mode to create or change the pin configuration. You can only
disable or enable pin connections in the Live Mode.

These settings are stored at the device level. They are not stored with presets or scene files, and do not
change when you switch to between presets on the device. You can store this configuration as a computer
file if you are working offline from the System Processor, or as a backup for archival purposes.

Preset Control Block
Initially there is no preset control block displayed in the window. Once you establish settings in the [#
Presets] and [Encoding Type] parameter boxes, a preset control block will appear on the left side of
the control pins section. The pin connection(s) can be alternately enabled and disabled by clicking on
the block with the left mouse button, or selecting [Disable] from the pull-down menu on the right side of
the block. For more information on preset encoding, refer to the Preset Encoding Types section.

Note:

After you have configured the device for external preset control, you cannot
change presets with the computer until you first disable the preset control
connection in the Control Pins window.
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Connection Blocks
The number of connection blocks that appear in the window depends on how many pins are available
after you have specified preset control. Allocate different controllers or logic output to a pin connection
by making a selection from the pull-down menu on the right-hand side of the block. The pin
connection(s) can be alternately enabled and
disabled by clicking on the block with the left
mouse button, or selecting [Disable] from the
pull-down menu. Figure 51 below illustrates the
available types of connection blocks.

100

Figure 51 − Connection Blocks

Processor Mapping Section
Use this section of the window to define, for each preset, which processors that the external hardware
will address. The input and output channels of the preset appear in a column below each pin allocation
block that has been assigned to a controller or logic output. Processor mapping can be designated
while you are in Live Mode or Design Mode. When you are in Live Mode the title bar of this section of
the window is blue, in Design Mode it is black.

Note:

Any processor mapping you specify will be saved with the preset or scene file, so
you must create a processor map that coordinates with the device's pin
configuration for each preset that will be stored in the device.

Processor Mapping Checkboxes
Click a checkbox to map the corresponding input or output channel to the allocation
block. The checkbox fills with blue when it is selected. You can assign multiple
processors to input controllers, but only one to logic output. Clicking the checkbox
toggles it in and out of selection. Figure 52 on the right illustrates the processor
mapping checkboxes.
Processor checkbox selected for mapping.
Checkbox de-selected.

Mutes
Channel muting can be controlled by either a locking switch or a momentary switch,
and can also be indicated at the logic output pins.
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Gains (Control Input Only)
Gain can be externally controlled by a 100k potentiometer. Directly under any connection block that is
assigned a pot controller is a gain scale, indicated by a blue bar. You can specify the range within which the
pot adjusts the level from –30B to +30dB maximum. The default range is –30dB to 0dB. Figure 53, below
on the left, illustrates the gain mapping checkboxes.
To edit the gain range adjusted by the pot:
1. Position the cursor anywhere along the scale
and click the left mouse button.
2. The Range Edit dialog appears, as pictured to
the right in figure 54.
3. Enter the appropriate range of gain adjustment
for the connected potentiometer.
4. Click [OK].
5. The new range is indicated by the length of
the blue bar.

Figure 54 − Range Edit Dialog

Figure 53 −
Gain Mapping

Note:

Use a 100K Audio Taper Pot with a tolerance of 5%. The majority of potentiometers have a tolerance
of 10% or 20%. If the open resistance of the pot is below 95K Ohms (greater than -5% tolerance), it
will not raise the signal gain sufficiently. However, you can use a 10% or 20% pot, as long as the
actual resistance value is greater than 95K Ohms.

Pin Configuration
Pin configuration is the second level of external control, and must be established before processor mapping
can be determined. The pin configuration section of the Control Pins window is a software model of the
connections wired to the hardware, which the device requires to properly recognize those connections. You can
store the configuration directly to the device, or save it to PC to be later transmitted to the System Processor.

Note:

You must be in Design Mode to create or change the pin configuration.

Creating a New Pin Configuration
1.

Go to Design Mode.

2.

Select [Devices>Control Pin Configuration] from the main menu.

3.

The Control Pins window opens.

4.

Select [Control In] or [Logic Out] view.

5.

Configure preset control.
a) Enter the number of presets [# Presets] value box.
b) Select an encoding type from the [Encoding Type] pull-down menu.
c) The preset control pins block appears in the pin configuration section of the window.
d) If you are using priority encoding for control input, enter the appropriate preset numbers under the
preset control block (see figure 55 on the following page).

6.

Configure any remaining pins for external controllers or logic output by making a selection from the pulldown menu on the right-hand side of each pin allocation block.

7.

Select the [Configuration>Store to Device] menu option.

8.

The Select Devices dialog will appear.

9.

Select a device and click [OK].

10. The pin configuration is stored to the device.
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Saving a Configuration to PC
1.

Follow steps 1-6 as above.

2.

Select the [Configuration>Save To PC] menu option.

3.

The Save Config As dialog opens.

4.

Navigate to the appropriate directory, enter a file name and click [OK].

5.

The configuration is stored to the computer as a file with a ".PIN" extension.

Editing an Existing Pin Configuration
1.

Go to Design Mode.

2.

Select [Devices>Control Pin Configuration] from the main menu.

3.

The Control Pins window opens.

4.

Select the [Configuration>Recall From Device] menu option.

5.

The Select Devices dialog will appear.

6.

Select a device and click [OK].

7.

The Control Pins window is populated with the current pin configuration.

8.

Make the necessary changes.

9.

Select the [Configuration>Store To Device] menu option.

10. The Select Devices dialog will appear.
11. Select a device and click [OK].
12. The pin configuration is stored to the device.

Preset Encoding Types
Currently there are three different types of preset encoding available for control input, and two for
control output. Select an encoding type based on the type of hardware you will be wiring to the control
pins, the number of presets you will be switching between in the device, and the number pins you will
require for other functions.

Priority or One-To-One Encoding
Maximum # of Presets:
8
Number of Pins Required:

1 to 8, one for each preset

Priority encoding for control input and one-to-one encoding for logic
output assigns each pin connection to a unique preset number.
This is the default encoding type when you enter up to 8 presets in
the [# Presets] value box.
For control input, the preset control block displays a value box
beneath each pin for specifying preset numbers, as pictured to the
right in figure 55. When the block initially appears, the default
values start at one and increment from left to right. These values
can be changed by clicking in each box and typing any number,
from 1 to 128. In the event that a user inadvertently presses a
combination of the external control switches, the device will change
to the highest priority preset.
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Binary Encoding
Maximum # of Presets:
Number of Pins Required:

128
Refer to the table on the right

# of Presets

# of Pins Required

2

1

4

2

Binary encoding equates a binary number with a System Processor
preset number for both control input and logic output. This is the
default encoding type when you enter 9 or more presets in the
[# Presets] value box.
The binary code corresponds to voltage states at the control pins
on the back of the System Processor device.
§ Logic 0 = pin lifted
§ Logic 1 = pin grounded

8

3

16

4

32

5

64

6

128

7

You can calculate the binary code that the System Processor uses to encode presets by using the
instructions below, or refer to Appendix A: Binary Encoding Tables on page 94 for complete binary
encoding tables for one to seven pins.
1.
2.

To convert the preset number to binary code:
Take the preset number and subtract 1.
Convert that number to its binary equivalent, observing the following convention:
The most significant bit always corresponds to pin 1, and the least significant bit always corresponds to
the highest pin number among those that are wired for preset control, as illustrated below in figure 56.
Example – Preset #7:

§
§

7–1=6
6 in binary = 110

Figure 56 − Binary Encoding Preset #7 for Three, Four, and Five Pins

Note:

For accurate preset switching at control input, the binary encoding for any preset
must contain the same number of bits as there are control pins wired for preset
encoding. Add zeros to the left of the binary value until there are the same
number of numerals as there are control pins wired for preset encoding, as
illustrated above in figure 56.

Custom Switch Encoding (Control Input Only)
Maximum # of Presets:
10
Number of Pins Required:

1

Custom switch encoding for control input equates resistor values with preset
numbers one through ten. This type of encoding is only available when you
enter a value of 10 or lower in the [# Presets] value box. Refer to Table 3 in
the Control Pins Connections section of the Hardware Installation guide for
more information on which resistor values equate to preset numbers.
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Connection Types
Any pins not used for preset control can be allocated for processor control and logic output. The
following table illustrates the available options for those connections. Click on the pull-down menu
indicated by the yellow arrow on the right side of the allocation block to select a controller type.
Pin
Allocation

Description

IN/OUT

Application

Locking Switch

IN

Muting input and output channels. Intended for use with an external
controller that flips between two positions. Can also be used with a
momentary switch, in which case the channel will be muted when the switch
is depressed, and un-muted when it is released.

Momentary Switch

IN

Muting input and output channels. Intended for use with an external
momentary switch. Toggles the muting on or off each time the switch is
depressed.

100k Potentiometer

IN

Adjusting gain within a range that you define, from –30dB to +30dB
maximum.

Logic Output

OUT

Indicating mute status to external devices such as LED's, relays, or binary
logic hardware.

Processor Mapping
Processor mapping is the third and final level of external control. In order for external devices to control System
Processor gain and channel muting, or to recognize mute status, each preset in the device must be mapped to
the control connections. Processor maps are stored with each preset or scene file. Use one of the following
methods to map each preset:

§
§
§

Create a template on which to base each preset.
Recall each preset from the device and add a processor map.
Open each scene file from PC and add a processor map.

Note:

Before creating a processor map, you must first configure the control pins.

Creating a Processor Map Template
If you will be storing multiple presets in the device, you can save time mapping processors by creating
a preset or scene file template on which to base the set of presets. This template can contain the
channel names, processor map, and any other general signal flow configuration features appropriate
for each preset stored in that particular device.
To create a preset template that includes a processor map:
1.

In Design Mode, name the input and output channels to reflect the particular device.
(Refer to the Labeling Inputs and Outputs section on page 17 for instructions.)

2.

Select [Devices>Control Pin Configuration] from the main menu.

3.

The Control Pins window opens.

4.

Load the appropriate pin configuration using one of the following methods:
§ Select the [Configuration>Open From PC] menu option.
§ If you are connected to the System Processor, select the
[Configuration>Recall From Device] menu option.

4.

The input and output channels appear in the processor mapping section of the window underneath
the connection blocks that have been allocated to controllers or logic output.

5.

For each allocated connection block, click the processor mapping checkboxes next to the
channels that will be addressed by the connection.
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6.

Close the Control Pins window.

7.

Save the scene file to PC. (Refer to the Scene Files section on page 27 for instructions.)

8.

Use this template file as basis for each preset that you create for the device.

Mapping an Existing Preset or Scene File
Existing presets can be mapped after they have been stored to the device and scene files can be
mapped after they have been saved to PC.
To map an existing preset in Live Mode:
1.

Go live with the device.

2.

Select a preset to map.

3.

The main window enters preview mode.

4.

Verify you have selected the correct preset and click [Load].

5.

The selected preset becomes active.

6.

Select [Devices>Control Pin Configuration] from the main menu.

7.

The Control Pins window opens with the input and output channels listed under the allocated pin
connections.

8.

For each allocated connection block, click the processor mapping checkboxes next to the
channels that will be addressed by the connection.

9.

The mapping is stored with the preset in the device.

10. Select another preset to map (it is not necessary to close the Control Pins window).

1.
2.
3.
4.
5.
6.
7.
8.

9.

To map an existing scene file in Design Mode:
Verify you are in Design Mode.
Click the [Open] button on the control bar of the main window.
The Open Scene dialog appears.
Select the scene file to map and click [OK].
The selected preset populates the signal flow diagram.
Select [Devices>Control Pin Configuration] from the main menu.
The Control Pins window opens.
Load the appropriate pin configuration using one of the following methods:
§ Select the [Configuration>Open From PC] menu option.
§ If you are connected to the System Processor, select the
[Configuration>Recall From Device] menu option.
For each allocated connection block, click the processor mapping checkboxes next to the
channels that will be addressed by the connection.

10. Go back to the main window (it is not necessary to close the Control Pins window).
11. Save the scene file to PC. (Refer to the Scene Files section on page 27 for instructions.)
12. Open another scene file to map.
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SECURITY ______________________________________________
Security is an optional feature that allows the installer, or other security administrator, to restrict the end user's
access to System Processor settings via the computer. The administrator is the individual who sets the device's
password and the access level at which it will operate after it is installed. There are three different user access
levels for the device:

Level One
When the device is set to level one, the user has unrestricted access to System Processor functions,
except for two functions that are always protected by the administrator password:
1. Setting the security level of the device.
2. Changing the administrator password.

Level Two
When the device is set to level two, the user has limited access, as defined by the security
administrator. The following System Processor access can be allowed for level two:
§ Preset changes via PC.
§ Changes to Matrix Mixer signal routing.
§ Access to modify processor settings for any blocks that are not locked by
the administrator (see the Individual Processor Security section on page 87 for
more information).

Level Three
This level permits read-only access to System Processor settings for the current live preset.

Note:

Security only affects access through the software interface. It does not restrict
external device control via the control pins or MIDI.

Establishing Device Security
Establishing security should be the final phase in setting up the device. There are two primary steps in setting
the device security, as described below.

Create a Password
Before you can set the user access level in the device, you
must create the password that protects your access as the
security administrator.
1.
2.
3.
4.
5.
6.

To create a password:
Go into Live Mode with the device.
Select [Security>Set Password] from the main menu.
The Create Password dialog appears, as pictured
to the right in figure 58.
Enter a password in the [Administrator Password] field.
TAB to the [Confirm Password] field and retype
Figure 58 − Create Password Dialog
the password.
Fill out the [Administrator Name] and [Phone or Contact info] fields.

Note:

All entries in the Create Password dialog are limited to a length of fifteen
characters.
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Set the User Access Level
Once you create a password, the device is automatically
set to user access level one. If access to the device
must be further restricted, set the device to the
appropriate access level.
1.
2.
3.
4.
5.
6.
7.
8.

To set the user access level:
Go into Live Mode with the device.
Select [Security>Level] from the
main menu.
The Password Required dialog appears, as
pictured to the right in figure 59.
Enter the password and click [OK].
The Set Security dialog appears, as pictured
to the right in figure 60.
Click the radio button to the left of the
appropriate level.
Specify custom options for level two,
if applicable.
Click [OK].

Figure 59 − Password Required Dialog

Changing Device Security

Figure 60 − Set Security Dialog

In the event that changes to device configuration or security settings are required after access has been restricted,
you must first change the device security back to user access level one before you can continue.

Note:

The security administrator password is required for these functions.

Changing the Access Level
Follow the instructions listed above for setting the access level.

Changing the Password
1.
2.
3.

4.
5.
6.
7.
8.

To change an existing password:
Go into Live Mode with the device.
Select [Security>Set Password] from the
main menu.
The Set Password dialog appears, as pictured to
the right in figure 61. The cursor is located in the
[Old Password] field.
Enter the current password.
TAB to the [Administrator Password] field and enter
the new password.
TAB to the [Confirm Password] field and retype the
Figure 61 − Set Password Dialog
new password.
Change the [Administrator Name] and [Phone or Contact info] if necessary.
Click [OK].

Note:

All entries in the Set Password dialog are limited to a length of fifteen characters.
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Removing Security
Device security can be completely reset to default status so that others may set an administrator
password and define user access levels.
To remove password protection:
1.

Go into Live Mode with the device.

2.

Select [Security>Set Password] from the main menu.

3.

The Set Password dialog appears, as pictured in figure 61, on the previous page.

4.

Type the current password in the [Old Password] field and press ENTER or Click [OK].

5.

Optionally, delete the administrator name and contact info.

6.

Leave the [Administrator Password] and [Confirm Password] fields blank.

7.

Click [OK].

8.

All access restrictions are removed.

Note:

Any individual processor block security attributes remain, but they are not
in effect until the device is set to user access level two.

Individual Processor Security
Individual processor security locks out access to specific processor blocks in a preset. You can lock access to
a single block, multiple blocks, or all blocks in a preset. You would use this feature, for example, if you wanted
the end user to be able to change gain settings but not PEQ settings. A locked processor can still be opened to
monitor meter levels or view settings.
While the user access level is device specific, processor block security is preset specific. Moreover, individual
processor security is a separate attribute of each block. For example, you can set the lock attribute on a block,
and when you copy that block, its security attribute is copied with it. This attribute remains whether you are
working in Design Mode or Live Mode.
To lock processor blocks:
1.

Go into Live Mode with the device.

2.

Verify that the device is set to Security – Level 1.

3.

Click to highlight a processor block, or CTRL+Click to make a multiple selection.

4.

Select [Security>Level 2>Lock Selected] from the main menu.

5.

A check mark appears beside this menu option to indicate the selected processor is locked.

6.

Set the device to user access level two.

Note:

You can lock processor blocks when you are in Design Mode, but it will not take
effect until the scene file is stored in a device as a preset, and security on that
device is set to level two.
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PRINTING REPORTS _____________________________________
The P4800 software provides printed reports to document all of the presets and settings that are
stored in the device. These reports are designed for the following uses.
1. To document the device configuration for the customer and end user.
2. To provide a hard-copy backup so that if necessary the device configuration can be
reconstructed.

Note:

1.
2.
3.
4.
5.
6.
7.

The reports are output directly to the printer, rather than to a file, so
you must be connected to a printer to use this feature.

To print P4800 reports:
Select File>Print from the main menu.
The Choose Report dialog opens, as pictured to the right
in figure 62.
Click to select the report you would like to print.
A dialog will open for the report you have specified.
Specify the information to include in the report, as
described in the following section.
Click [OK].
The Windows Print dialog appears.
Figure 62 − Choose Report Dialog

P4800 Reports
Device Information
The Device Information report lists all device-level information, except for the security
password. When the Device Information dialog opens, select the device for which you would
like to print a report from the [Device] pull-down list. Enter the information pertinent to the
selected device and click [OK]. The information you enter here appears only on the immediate
report; it is not stored for future use. Refer to page 90 for a sample of this report.

Figure 63 − Device Information Dialog
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Preset Information and Current Preset Information
The Preset Information report lists the details of a specific preset that is stored in the device.
When the Preset Information dialog opens, select the device for which you would like to print
a report from the [Device] pull-down list. Then select the preset for which you would like to
print a report and click [OK]. Refer to pages 91 and 92 for a report sample.
The Current Preset Information report is identical. It lists the details of the currently displayed
preset or scene.

Figure 64 − Preset Information Dialog

Figure 65 − Current Preset Information Dialog

Processor Information
The Processor Information report lists the settings of one or more processor blocks. The
Processor Information Dialog displays a list of all fixed and drag-and-drop processors from the
currently displayed scene or preset. Click to select a processor, or SHIFT+Click to select more
than one, then click [OK]. Refer to page 93 for a sample of this report.

Figure 66 − Processor Information Dialog
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Report Samples
DEVICE INFORMATION
Installation Information:
Location:

4325 W. Division, Chicago

Client:

Sacred Heart School

Designer:

Bob Reiling

Installer:

RC Communications

System Description:
Main Gymnasium System Processor

Hardware Information:
ShureLink Device ID:

15

Device Name:

Gymnasium

Control Input Pin Configuration:
Pin-1: Encoding Type: Priority, Mapped to preset: 1
Pin-2: Encoding Type: Priority, Mapped to preset: 2
Pin-3: Encoding Type: Priority, Mapped to preset: 3
Pin-4: Encoding Type: Priority, Mapped to preset: 4
Pin-5: Switch
Pin-6: Potentiometer
Pin-7: Potentiometer
Pin-8: NONE [DISABLED]
Control Output Pin Configuration:
Pin-1: Encoding Type: One to One, Mapped to preset: 1
Pin-2: Encoding Type: One to One, Mapped to preset: 2
Pin-3: Encoding Type: One to One, Mapped to preset: 3
Pin-4: Encoding Type: One to One, Mapped to preset: 4
Pin-5: Logic Control
Pin-6: Logic Control [DISABLED]
Pin-7: Logic Control [DISABLED]
Pin-8: Logic Control [DISABLED]
Preset Information:
Total Presets:

4
Preset 1

Concert

Preset 2

Assembly

Preset 3

Game

Preset 4

Dance

1 of 1
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PRESET INFORMATION:
Preset ID:

2

Preset Name:

Assembly

Descripiton:

Preliminary tuning.

Control Input Pin Mapping:
Pin-1: Reserved for Preset Control - See Device Information
Pin-2: Reserved for Preset Control - See Device Information
Pin-3: Reserved for Preset Control - See Device Information
Pin-4: Reserved for Preset Control - See Device Information
Pin-5: Mutes: Input: 2
Pin-6: Gains: Input: 1 2 , Gain Range: -30.0 to 30.0 dB
Pin-7: Gains: Output: 1 2 3 4 5 6 7 8 , Gain Range: -30.0 to 30.0 dB
Pin-8: N/A
Control Output Pin Mapping:
Pin-1: Reserved for Preset Display - See Device Information
Pin-2: Reserved for Preset Display - See Device Information
Pin-3: Reserved for Preset Display - See Device Information
Pin-4: Reserved for Preset Display - See Device Information
Pin-5: Mutes: Input: 2
Pin-6: Mutes: N/A
Pin-7: Mutes: N/A
Pin-8: Mutes: N/A

1 of 2
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Drag and Drop Processors:
Input-1, Slot-1, Processor: PEQ 10CS
Input-1, Slot-2, Processor: N/A
Input-1, Slot-3, Processor: N/A
Input-1, Slot-4, Processor: N/A
Input-1, Slot-5, Processor: SFT LIM

Input-3, Slot-1, Processor: N/A
Input-3, Slot-2, Processor: N/A
Input-3, Slot-3, Processor: N/A
Input-3, Slot-4, Processor: N/A
Input-3, Slot-5, Processor: N/A

Input-2, Slot-1, Processor: PEQ 10CS
Input-2, Slot-2, Processor: GEQ30
Input-2, Slot-3, Processor: N/A
Input-2, Slot-4, Processor: N/A
Input-2, Slot-5, Processor: N/A

Input-4, Slot-1, Processor: N/A
Input-4, Slot-2, Processor: N/A
Input-4, Slot-3, Processor: N/A
Input-4, Slot-4, Processor: N/A
Input-4, Slot-5, Processor: N/A

Output-1, Slot-1, Processor: PEQ 10CS
Output-1, Slot-2, Processor: CUT/SHELF
Output-1, Slot-3, Processor: N/A
Output-1, Slot-4, Processor: N/A
Output-1, Slot-5, Processor: N/A
Output-1, Slot-6, Processor: N/A

Output 5, Slot-1, Processor: PEQ 5CS
Output-5, Slot-2, Processor: N/A
Output-5, Slot-3, Processor: N/A
Output-5, Slot-4, Processor: N/A
Output-5, Slot-5, Processor: N/A
Output-5, Slot-6, Processor: DLY 150ms

Output-2, Slot-1, Processor: PEQ 5CS
Output-2, Slot-2, Processor: N/A
Output-2, Slot-3, Processor: N/A
Output-2, Slot-4, Processor: N/A
Output-2, Slot-5, Processor: N/A
Output-2, Slot-6, Processor: N/A

Output-6, Slot-1, Processor: PEQ 5CS
Output-6, Slot-2, Processor: N/A
Output-6, Slot-3, Processor: N/A
Output-6, Slot-4, Processor: N/A
Output-6, Slot-5, Processor: N/A
Output-6, Slot-6, Processor: DLY 150ms

Output-3, Slot-1, Processor: PEQ 5CS
Output-3, Slot-2, Processor: N/A
Output-3, Slot-3, Processor: N/A
Output-3, Slot-4, Processor: N/A
Output-3, Slot-5, Processor: N/A
Output-3, Slot-6, Processor: N/A

Output-7, Slot-1, Processor: N/A
Output-7, Slot-2, Processor: N/A
Output-7, Slot-3, Processor: AGC
Output-7, Slot-4, Processor: SFT LIM
Output-7, Slot-5, Processor: N/A
Output-7, Slot-6, Processor: DLY 150ms

Output-4, Slot-1, Processor: PEQ 5CS
Output-4, Slot-2, Processor: N/A
Output-4, Slot-3, Processor: N/A
Output-4, Slot-4, Processor: N/A
Output-4, Slot-5, Processor: N/A
Output-4, Slot-6, Processor: DLY 150ms

Output-8, Slot-1, Processor: PEQ 3CS
Output-8, Slot-2, Processor: N/A
Output-8, Slot-3, Processor: AGC
Output-8, Slot-4, Processor: LIM
Output-8, Slot-5, Processor: N/A
Output-8, Slot-6, Processor: DLY 150ms

2 of 2
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PROCESSOR INFORMATION:
Input Gain Block
Security: Unlocked
Input-1:, Name: Main input, Operating Level: +4 dBu, Polarity: + , Gain: -4.5dB, Pad: On, Mute: Off, Link Group: N/A
Input-2:, Name: Foyer, Operating Level: +4 dBu, Polarity: + , Gain: 8.5dB, Pad: On, Mute: Off, Link Group: N/A
Input-3:, Name: Record AUX, Operating Level: +4 dBu, Polarity: + , Gain: 0.0dB, Pad: On, Mute: On, Link Group: N/A
Input-4:, Name: Not used, Operating Level: +4 dBu, Polarity: + , Gain: -4.5dB, Pad: On, Mute: Off, Link Group: N/A

Input-1, Slot-1, Processor: PEQ 10CS
Name: PEQ with CS, Link Group: N/A, Security: Unlocked
Bypass: Off
Filter: L, Type: Shelf, Freq: 0.0kHz, Gain: 0.0dB, Width(oct):
Filter: H, Type: Shelf, Freq: 20.0kHz, Gain: 0.0dB, Width(oct):
Filter: 3, Freq: 0.1kHz, Gain: -2.0dB, Width(oct): 2/3
Filter: 4, Freq: 2.2kHz, Gain: -6.0dB, Width(oct): 1/10
Filter: 5, Freq: 0.3kHz, Gain: -4.5dB, Width(oct): 1/3
Filter: 6, Freq: 5.0kHz, Gain: 2.5dB, Width(oct): 1
Filter: 7, Freq: 2.7kHz, Gain: -3.0dB, Width(oct): 1/2

Input-1, Slot-5, Processor: SFT LIM
Name: Soft Limiter, Link Group: N/A, Security: Unlocked
Bypass: Off
Threshold: 9.5 VU, Attack: 2ms, Ratio: 100.0, Decay: 50ms
Input Gain: 0.00, Output Gain: 0.00
Knee Soft

Input-2, Slot-1, Processor: PEQ 10CS
Name: PEQ with CS, Link Group: N/A, Security: Unlocked
Bypass: Off
Filter: L, Type: Shelf, Freq: 0.1kHz, Gain: -18.5dB, Width(oct):
Filter: H, Type: Shelf, Freq: 10.9kHz, Gain: -18.5dB, Width(oct):
Filter: 3, Freq: 4.3kHz, Gain: -9.0dB, Width(oct): 2/3
Filter: 4, Freq: 0.7kHz, Gain: 4.5dB, Width(oct): 1
Filter: 5, Freq: 0.2kHz, Gain: -9.0dB, Width(oct): 1/6
Filter: 6, Freq: 0.1kHz, Gain: -6dB, Width(oct): 1/3
Filter: 7, Freq: 6.8kHz, Gain: -6.0dB, Width(oct): 1/6

1 of 1
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APPENDIX A: BINARY ENCODING TABLES __________________
The following tables list the binary encoding for System Processor presets. Apply this encoding to the control
input pins to switch the device to the corresponding preset. The System Processor indicates the current live
preset at the logic output pins with this encoding.

One-Pin Binary Encoding
PRESET #

PIN 1

1

O

2

I

Two-Pin Binary Encoding
PRESET #

PIN 1

PIN 2

1

O

O

2

O

I

3

I

O

4

I

I

Three-Pin Binary Encoding
PRESET #

PIN 1

PIN 2

PIN 3

1

O

O

O

2

O

O

I

3

O

I

O

4

O

I

I

5

I

O

O

6

I

O

I

7

I

I

O

8

I

I

I

0 = Pin Lifted 1 = Pin Grounded
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Four-Pin Binary Encoding
PRESET #

PIN 1

PIN 2

PIN 3

PIN 4

1

O

O

O

O

2

O

O

O

I

3

O

O

I

O

4

O

O

I

I

5

O

I

O

O

6

O

I

O

I

7

O

I

I

O

8

O

I

I

I

9

I

O

O

O

10

I

O

O

I

11

I

O

I

O

12

I

O

I

I

13

I

I

O

O

14

I

I

O

I

15

I

I

I

O

16

I

I

I

I

0 = Pin Lifted 1 = Pin Grounded
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Five-Pin Binary Encoding
PRESET #

PIN 1

PIN 2

PIN 3

PIN 4

PIN 5

1

O

O

O

O

O

2

O

O

O

O

I

3

O

O

O

I

O

4

O

O

O

I

I

5

O

O

I

O

O

6

O

O

I

O

I

7

O

O

I

I

O

8

O

O

I

I

I

9

O

I

O

O

O

10

O

I

O

O

I

11

O

I

O

I

O

12

O

I

O

I

I

13

O

I

I

O

O

14

O

I

I

O

I

15

O

I

I

I

O

16

O

I

I

I

I

17

I

O

O

O

O

18

I

O

O

O

I

19

I

O

O

I

O

20

I

O

O

I

I

21

I

O

I

O

O

22

I

O

I

O

I

23

I

O

I

I

O

24

I

O

I

I

I

25

I

I

O

O

O

26

I

I

O

O

I

27

I

I

O

I

O

28

I

I

O

I

I

29

I

I

I

O

O

30

I

I

I

O

I

31

I

I

I

I

O

32

I

I

I

I

I

0 = Pin Lifted 1 = Pin Grounded
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Six-Pin Binary Encoding
PRESET #

PIN 1

PIN 2

PIN 3

PIN 4

PIN 5

PIN 6

1

O

O

O

O

O

O

2

O

O

O

O

O

I

3

O

O

O

O

I

O

4

O

O

O

O

I

I

5

O

O

O

I

O

O

6

O

O

O

I

O

I

7

O

O

O

I

I

O

8

O

O

O

I

I

I

9

O

O

I

O

O

O

10

O

O

I

O

O

I

11

O

O

I

O

I

O

12

O

O

I

O

I

I

13

O

O

I

I

O

O

14

O

O

I

I

O

I

15

O

O

I

I

I

O

16

O

O

I

I

I

I

17

O

I

O

O

O

O

18

O

I

O

O

O

I

19

O

I

O

O

I

O

20

O

I

O

O

I

I

21

O

I

O

I

O

O

22

O

I

O

I

O

I

23

O

I

O

I

I

O

24

O

I

O

I

I

I

25

O

I

I

O

O

O

26

O

I

I

O

O

I

27

O

I

I

O

I

O

28

O

I

I

O

I

I

29

O

I

I

I

O

O

30

O

I

I

I

O

I

31

O

I

I

I

I

O

32

O

I

I

I

I

I

33

I

O

O

O

O

O

34

I

O

O

O

O

I

35

I

O

O

O

I

O

36

I

O

O

O

I

I

37

I

O

O

I

O

O

38

I

O

O

I

O

I

39

I

O

O

I

I

O

40

I

O

O

I

I

I

0 = Pin Lifted 1 = Pin Grounded
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PRESET #

PIN 1

PIN 2

PIN 3

PIN 4

PIN 5

PIN 6

41

I

O

I

O

O

O

42

I

O

I

O

O

I

43

I

O

I

O

I

O

44

I

O

I

O

I

I

45

I

O

I

I

O

O

46

I

O

I

I

O

I

47

I

O

I

I

I

O

48

I

O

I

I

I

I

49

I

I

O

O

O

O

50

I

I

O

O

O

I

51

I

I

O

O

I

O

52

I

I

O

O

I

I

53

I

I

O

I

O

O

54

I

I

O

I

O

I

55

I

I

O

I

I

O

56

I

I

O

I

I

I

57

I

I

I

O

O

O

58

I

I

I

O

O

I

59

I

I

I

O

I

O

60

I

I

I

O

I

I

61

I

I

I

I

O

O

62

I

I

I

I

O

I

63

I

I

I

I

I

O

64

I

I

I

I

I

I

0 = Pin Lifted 1 = Pin Grounded
SHURE P4800 System Processor Software Guide

Page 98 of 108

Appendix A

Seven-Pin Binary Encoding
PRESET #

PIN 1

PIN 2

PIN 3

PIN 4

PIN 5

PIN 6

PIN 7

1

O

O

O

O

O

O

O

2

O

O

O

O

O

O

I

3

O

O

O

O

O

I

O

4

O

O

O

O

O

I

I

5

O

O

O

O

I

O

O

6

O

O

O

O

I

O

I

7

O

O

O

O

I

I

O

8

O

O

O

O

I

I

I

9

O

O

O

I

O

O

O

10

O

O

O

I

O

O

I

11

O

O

O

I

O

I

O

12

O

O

O

I

O

I

I

13

O

O

O

I

I

O

O

14

O

O

O

I

I

O

I

15

O

O

O

I

I

I

O

16

O

O

O

I

I

I

I

17

O

O

I

O

O

O

O

18

O

O

I

O

O

O

I

19

O

O

I

O

O

I

O

20

O

O

I

O

O

I

I

21

O

O

I

O

I

O

O

22

O

O

I

O

I

O

I

23

O

O

I

O

I

I

O

24

O

O

I

O

I

I

I

25

O

O

I

I

O

O

O

26

O

O

I

I

O

O

I

27

O

O

I

I

O

I

O

28

O

O

I

I

O

I

I

29

O

O

I

I

I

O

O

30

O

O

I

I

I

O

I

31

O

O

I

I

I

I

O

32

O

O

I

I

I

I

I

33

O

I

O

O

O

O

O

34

O

I

O

O

O

O

I

35

O

I

O

O

O

I

O

36

O

I

O

O

O

I

I

37

O

I

O

O

I

O

O

38

O

I

O

O

I

O

I

39

O

I

O

O

I

I

O

40

O

I

O

O

I

I

I

41

O

I

O

I

O

O

O

42

O

I

O

I

O

O

I

43

O

I

O

I

O

I

O

0 = Pin Lifted 1 = Pin Grounded
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PRESET #

PIN 1

PIN 2

PIN 3

PIN 4

PIN 5

PIN 6

PIN 7

44

O

I

O

I

O

I

I

45

O

I

O

I

I

O

O

46

O

I

O

I

I

O

I

47

O

I

O

I

I

I

O

48

O

I

O

I

I

I

I

49

O

I

I

O

O

O

O

50

O

I

I

O

O

O

I

51

O

I

I

O

O

I

O

52

O

I

I

O

O

I

I

53

O

I

I

O

I

O

O

54

O

I

I

O

I

O

I

55

O

I

I

O

I

I

O

56

O

I

I

O

I

I

I

57

O

I

I

I

O

O

O

58

O

I

I

I

O

O

I

59

O

I

I

I

O

I

O

60

O

I

I

I

O

I

I

61

O

I

I

I

I

O

O

62

O

I

I

I

I

O

I

63

O

I

I

I

I

I

O

64

O

I

I

I

I

I

I

65

I

O

O

O

O

O

O

66

I

O

O

O

O

O

I

67

I

O

O

O

O

I

O

68

I

O

O

O

O

I

I

69

I

O

O

O

I

O

O

70

I

O

O

O

I

O

I

71

I

O

O

O

I

I

O

72

I

O

O

O

I

I

I

73

I

O

O

I

O

O

O

74

I

O

O

I

O

O

I

75

I

O

O

I

O

I

O

76

I

O

O

I

O

I

I

77

I

O

O

I

I

O

O

78

I

O

O

I

I

O

I

79

I

O

O

I

I

I

O

80

I

O

O

I

I

I

I

81

I

O

I

O

O

O

O

82

I

O

I

O

O

O

I

83

I

O

I

O

O

I

O

84

I

O

I

O

O

I

I

85

I

O

I

O

I

O

O

86

I

O

I

O

I

O

I

87

I

O

I

O

I

I

O

88

I

O

I

O

I

I

I

0 = Pin Lifted 1 = Pin Grounded
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PRESET #

PIN 1

PIN 2

PIN 3

PIN 4

PIN 5

PIN 6

PIN 7

89

I

O

I

I

O

O

O

90

I

O

I

I

O

O

I

91

I

O

I

I

O

I

O

92

I

O

I

I

O

I

I

93

I

O

I

I

I

O

O

94

I

O

I

I

I

O

I

95

I

O

I

I

I

I

O

96

I

O

I

I

I

I

I

97

I

I

O

O

O

O

O

98

I

I

O

O

O

O

I

99

I

I

O

O

O

I

O

100

I

I

O

O

O

I

I

101

I

I

O

O

I

O

O

102

I

I

O

O

I

O

I

103

I

I

O

O

I

I

O

104

I

I

O

O

I

I

I

105

I

I

O

I

O

O

O

106

I

I

O

I

O

O

I

107

I

I

O

I

O

I

O

108

I

I

O

I

O

I

I

109

I

I

O

I

I

O

O

110

I

I

O

I

I

O

I

111

I

I

O

I

I

I

O

112

I

I

O

I

I

I

I

113

I

I

I

O

O

O

O

114

I

I

I

O

O

O

I

115

I

I

I

O

O

I

O

116

I

I

I

O

O

I

I

117

I

I

I

O

I

O

O

118

I

I

I

O

I

O

I

119

I

I

I

O

I

I

O

120

I

I

I

O

I

I

I

121

I

I

I

I

O

O

O

122

I

I

I

I

O

O

I

123

I

I

I

I

O

I

O

124

I

I

I

I

O

I

I

125

I

I

I

I

I

O

O

126

I

I

I

I

I

O

I

127

I

I

I

I

I

I

O

128

I

I

I

I

I

I

I

0 = Pin Lifted 1 = Pin Grounded
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APPENDIX B: DSP USAGE PER PROCESSOR ________________
The following table lists the percentage of DSP resources each processor uses. DSP resources determined by:
§ The combination of processors you are using
§ The position of the processors in the signal flow diagram
The first [% of DSP] column lists the percentage of DSP resources each processor uses in a P4800 with a
serial number starting the letter N or higher.
The second [% of DSP] column lists the percentages of DSP resources each processor uses in a P4800 with a
serial number starting with the letters L or M.
Note: You cannot accurately estimate the DSP resources a configuration will use by simply adding the
percentage listed in this table.

CATEGORY
Graphic EQ

Parametric EQ

DFR

Delay

Dynamics

DESCRIPTION

BLOCK NAME

% of DSP

% of DSP

N or Higher

L or M

GEQ 10

10 Band Graphic Equalizer

3.5

3.9

GEQ 30

30 Band Graphic Equalizer

7.7

8.5

PEQ 3

3 Band Parametric Equalizer

2.1

2.3

PEQ 5

5 Band Parametric Equalizer

2.5

2.8

PEQ 7

7 Band Parametric Equalizer

2.9

3.3

PEQ 10

10 Band Parametric Equalizer

3.5

3.9

PEQ 3 + C/S

3 Band Parametric Equalizer With Cut/Shelf Filters

2.5

2.8

PEQ 5 + C/S

5 Band Parametric Equalizer With Cut/Shelf Filters

2.9

3.3

PEQ 7 + C/S

7 Band Parametric Equalizer With Cut/Shelf Filters

3.3

3.7

PEQ 10 + C/S

10 Band Parametric Equalizer With Cut/Shelf Filters

4.0

4.4

CUT/SHELF

High and Low Cut/High and Low Shelf Filters

2.7

3.0

DFR5

5 Band Digital Feedback Reducer

11.1

12.4

DFR10

10 Band Digital Feedback Reducer

12.4

13.8

DLY 5ms

5 ms Maximum Delay

3.3

3.7

DLY 150ms

150 ms Maximum Delay

3.3

3.7

DLY 500ms

500 ms Maximum Delay

3.3

3.7

DLY 2s

2 Second Maximum Delay

3.3

3.7

COMP

Compressor

2.1

2.3

SFT COMP

Compressor – Soft Knee Option

2.3

2.6

ST COMP

Stereo Compressor

4.2

4.6

SFT ST COMP

Stereo Compressor – Soft Knee Option

5.6

6.2

LIM

Limiter

2.1

2.3

SFT LIM

Limiter – Soft Knee Option

2.3

2.6

ST LIM

Stereo Limiter

4.2

4.6

SFT ST LIM

Stereo Limiter – Soft Knee Option

5.6

6.2

AGC

Automatic Gain Control

2.9

3.2

GATE
DOWN EXP

Gate
Downward Expander

2.4
2.4

2.2
2.7

PEAKLIM

Peak Limiter

2.8

3.2

DUCK

Ducker

3.5

3.9
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Crossover

XOVER 2

2-way Crossover

3.7

4.1

XOVER 3

3-way Crossover

4.7

5.2

XOVER 4

4-way Crossover

5.7

6.4

XOVER 5

5-way Crossover

6.7

7.5

SPLIT 2

2-way Splitter

0.9

1.0

SPLIT 3

3-way Splitter

1.0

1.1

SPLIT 4

4-way Splitter

1.2

1.3

SPLIT 5

5-way Splitter

1.4

1.5
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APPENDIX C: FILE EXTENSIONS ___________________________
The following table lists the extensions of all of the different types of files created by the System
Processor software.
Source

File Extension
.agc

Automatic Gain Control

.backup

Total Device Backup

.cdk

Input and Outuput Gain

.comp

Compressor

.cutshf

High and Low Cut/High and Low Shelf Filters

.dfr10

10 Band Digital Feedback Reducer

.dfr5

5 Band Digital Feedback Reducer

.dly150ms

150 ms Maximum Delay

.dly2s

2 Second Maximum Delay

.dly500ms

500 ms Maximum Delay

.dly5ms

5 ms Maximum Delay

.duck

Ducker

.exp

Downward Expander

.gate

Gate

.geq10

10 Band Graphic EQ

.geq30

30 Band Graphic EQ

.lim

Limiter

.mix

Matrix Mixer

.peaklim

Peak Stop Limiter

.peq10

10 Band Parametric EQ

.peq10cs

10 Band Parametric EQ With Cut/Shelf Filters

.peq3

3 Band Parametric EQ

.peq3cs

3 Band Parametric EQ With Cut/Shelf Filters

.peq5

5 Band Parametric EQ

.peq5cs

5 Band Parametric EQ With Cut/Shelf Filters

.peq7

7 Band Parametric EQ

.peq7cs

7 Band Parametric EQ With Cut/Shelf Filters

.pin

Pin Configuration

.scn

Scene File

.softcomp

Compressor – Soft Knee Option

.softlim

Limiter – Soft Knee Option

.softstcomp

Stereo Compressor – Soft Knee Option

.softstlim

Stereo Limiter – Soft Knee Option

.stcomp

Stereo Compressor

.stlim

Stereo Limiter

.xover2

2-way Crossover

.xover3

3-way Crossover

.xover4

4-way Crossover

.xover5

5-way Crossover
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APPENDIX D: TROUBLESHOOTING GUIDE ___________________
Communication fails between the computer and the P4800:
The following messages are displayed when the P4800 software fails to communicate with the device.

“COM(port) is already in use or does not exist...”
This message appears under the following conditions:
•

The specified COM port is already in use by another application.
If the COM port selected is already in use by another application, closing that application will resolve
the problem. An example of an application that keeps the COM port open is HotSync Manager and
similar utilities used for synchronizing the computer with Palm Pilot™ type devices. Closing these
programs might be difficult as they usually run as background applications. Consult the program’s user
manual. Desktop computers usually have more than one physical serial port. In this case, selecting a
different COM port and connecting the serial cable for the P4800 connection to a different serial port
might solve the problem.

•

The computer's serial port is disabled.
Run the BIOS setup utility and enable the serial port. When doing so, note the serial port settings (IRQ
and I/O address) and make sure there is a Windows COM port mapped to those settings. Then choose
that COM port in the P4800 software.

“Network not ready...”
This indicates that the P4800 software successfully opened the COM port but did not find a device
connected to it. Make sure the P4800 is powered on and has finished its boot up sequence before
attempting to communicate with the unit. If your computer has more than one COM port, verify you have
connected the network cable to the same COM port that you selected in the "Select COM Port" dialog.
Verify that you are using a standard DB9 serial cable and that it is securely connected to both the
computer and the P4800. Also, make sure that you are connected to the correct port at the device: the
RS232 is the most common port to use.

“No devices detected.”
The P4800 software has found a device other than a P4800 in the selected COM port. This may be a
modem or other serial device, such as a DFR11EQ. Selecting a different COM port to which the P4800
unit is connected will resolve this problem.

P4800 front panel displays a static LED pattern:
The front panel may show a strange LED pattern when the P4800 has an internal error, as in the
following examples:
•

The control pin supply current (5 Volt, 100 mA max.) has been exceeded or is shorted to ground –
Remove all control pin connections and cycle power to the device.

•

A corrupted scene exists in the device memory, which must be deleted. If the problem persists after
you follow the instructions below, contact Shure’s Applications Group.
1.
2.
3.

To delete corrupted presets:
Open the P4800 software and in Design Mode, select File>Delete Preset.
Delete any presets that show up as “Corrupted." If the LIVE preset proves to be the offending
preset, click [Cancel].
Select File>New to generate a blank scene, then select File>Store Preset and overwrite the
corrupted LIVE preset with the blank scene.
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•

The firmware update process has been interrupted, which can be corrected by following the
instructions below. If the problem persists, contact Shure’s Applications Group.
1.
2.
3.

To complete the firmware update:
Cycle power to the device.
From the [File} menu, select [Firmware Upgrade]..
When the software prompts you to update the code, click [Continue].

Unable to switch device presets from the computer:
•

Check the device's security level. In order to switch presets from the computer, the device must be set
either to security level 1, or customized level 2. For more information, refer to the Security section on
page 85.

•

If preset changes via control input pins are enabled, the unit will not respond to preset changes via the
software. To solve the problem, disable the control pins for preset change in the Control Pin window.
For more information, refer to the Preset Control Block section on page 78.

Software spontaneously changes from Live Mode to Design Mode:
When you are working in Live Mode and use devices connected to the control inputs to change
presets, mute channels or adjust volume, the software may switch to Design Mode. This is normal
operation. Monitoring external device control via the software is not currently a supported feature. This
situation is less likely to occur with faster computers.
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Appendix E

APPENDIX E: FIRMWARE UPGRADES _______________________
When connecting to a P4800 for the first time, you may be prompted to upgrade its firmware. If prompted, an
upgrade is required before you can use the new features and enhancements of the P4800 System Processor
version 4.0 software.

Before proceeding with the upgrade, you must disconnect all Shure Link cables and any external control
devices. You should also close all other open applications. Connect directly to the P4800 using an RS-232
cable.

You may then make a backup copy of all data in your P4800 by clicking on the [Backup Device] button and
following the instructions. When the backup is complete, the firmware upgrade will begin. Do not interrupt the
upgrade once it has begun!

Note: If the firmware upgrade fails for any reason (such as a power failure or a disconnected cable), you must
select [Firmware Upgrade] from the [File] menu to relaunch the upgrade process.
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.
SIA-Smaart is a registered trademark of SIA Software Company, Inc., and Smaart and SmaartLive are trademarks of
SIA Software Company, Inc. TEF is a trademark of Gold Line Connector, Inc.
.
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